Bug 1263177 - Data Tieirng:Change error message as detach-tier error message throws as "remove-brick"
Data Tieirng:Change error message as detach-tier error message throws as "rem...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
mainline
All All
urgent Severity low
: ---
: ---
Assigned To: hari gowtham
bugs@gluster.org
: Triaged
Depends On: 1258244
Blocks: 1260923
  Show dependency treegraph
 
Reported: 2015-09-15 05:29 EDT by hari gowtham
Modified: 2016-06-16 09:36 EDT (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1258244
Environment:
Last Closed: 2016-06-16 09:36:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description hari gowtham 2015-09-15 05:29:54 EDT
+++ This bug was initially created as a clone of Bug #1258244 +++

Description of problem:
=======================
when you try to detach a tier in a fail case, say when volume is offline, it talks about remove-brick as below:

volume detach-tier start: failed: Volume testme needs to be started before remove-brick (you can use 'force' or 'commit' to override this behavior)

Instead it should tell about "detach-tier"


Version-Release number of selected component (if applicable):



Version-Release number of selected component (if applicable):
==========================================================
[root@nag-manual-node1 ~]# gluster --version
glusterfs 3.7.3 built on Aug 27 2015 01:23:05
Repository revision: git://git.gluster.com/glusterfs.git
Copyright (c) 2006-2011 Gluster Inc. <http://www.gluster.com>
GlusterFS comes with ABSOLUTELY NO WARRANTY.
You may redistribute copies of GlusterFS under the terms of the GNU General Public License.
[root@nag-manual-node1 ~]# rpm -qa|grep gluster
glusterfs-libs-3.7.3-0.82.git6c4096f.el6.x86_64
glusterfs-fuse-3.7.3-0.82.git6c4096f.el6.x86_64
glusterfs-server-3.7.3-0.82.git6c4096f.el6.x86_64
glusterfs-3.7.3-0.82.git6c4096f.el6.x86_64
glusterfs-api-3.7.3-0.82.git6c4096f.el6.x86_64
glusterfs-cli-3.7.3-0.82.git6c4096f.el6.x86_64
python-gluster-3.7.3-0.82.git6c4096f.el6.noarch


Steps to Reproduce:
=====================
1.offline a tier volume
2.issue a detach-tier start, it throws wrong error telling about remove-brick instead of detach-tier
Comment 1 Vijay Bellur 2015-09-15 05:39:39 EDT
REVIEW: http://review.gluster.org/12177 (Tiering:Changing error message as detach-tier instead of "remove-brick") posted (#1) for review on master by hari gowtham (hari.gowtham005@gmail.com)
Comment 2 Niels de Vos 2016-06-16 09:36:54 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.