Bug 1263182 - Administrator able to rename directory even as it has no access to the directory
Administrator able to rename directory even as it has no access to the direc...
Status: CLOSED NOTABUG
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: samba (Show other bugs)
3.1
x86_64 Windows
unspecified Severity high
: ---
: ---
Assigned To: rhs-smb@redhat.com
storage-qa-internal@redhat.com
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-15 05:36 EDT by Vivek Das
Modified: 2015-09-15 09:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-15 09:47:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vivek Das 2015-09-15 05:36:29 EDT
Description of problem:

AD user changes the permission of a directory to Read Only for administrator but still administrator is able to rename that directory.

Version-Release number of selected component (if applicable):
samba-4.1.17-13.el7rhgs.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Login as an ADMINISTRATOR create a directory in samba share. eg. FOLDER_1
2. Set Read only permissions to FOLDER_1 for ADIMINISTRATOR.
3. Login as an ADMINISTRATOR
4. Rename the directory FOLDER_1

Actual results:
Administrator able to rename the directory.

Expected results:
Administrator should not be able to rename the directory when it has only read permissions.

Additional info:
Comment 2 Vivek Das 2015-09-15 09:46:38 EDT
This is not a bug rather rename is not a file operation thus one can rename the directory given that the parent directory do have a write permission.

Note You need to log in before you can comment on or make changes to this bug.