Bug 12632 - printf does not support "long long"
printf does not support "long long"
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: sh-utils (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: bero
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-19 14:05 EDT by Eugene Kanter
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-24 18:05:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eugene Kanter 2000-06-19 14:05:54 EDT
According to the manual page printf supposed to support all libc printf
data types.

However looking at the source reveals that it does not support long long
type.

I discovered it because ipfwadm-wrappers scripts fails when data goes over
2^32.
Comment 1 Bernhard Rosenkraenzer 2002-08-29 16:49:27 EDT
Feature added in 2.0.12-3.

Note You need to log in before you can comment on or make changes to this bug.