Bug 126320 - restart nscd on writing out resolv.conf
Summary: restart nscd on writing out resolv.conf
Status: CLOSED DUPLICATE of bug 125712
Alias: None
Product: Fedora
Classification: Fedora
Component: dhcp   
(Show other bugs)
Version: 2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jason Vas Dias
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-06-18 22:27 UTC by Havoc Pennington
Modified: 2007-11-30 22:10 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:04:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Havoc Pennington 2004-06-18 22:27:28 UTC
When changing network interfaces, glibc keeps using the old
resolv.conf for a while. Dan says restarting nscd is how we're
supposed to fix this.

Comment 1 Bill Nottingham 2004-06-29 04:57:29 UTC
Or not using nscd. :)

Comment 2 Havoc Pennington 2004-06-29 08:09:37 UTC
Ah, we need nscd for caching the gecos info for users though...



Comment 3 Jason Vas Dias 2004-07-29 13:45:08 UTC
We've been told by glibc developers that 
making nscd re-read resolv.conf on changes
is not an option .
If resolv.conf changes, restart nscd.


*** This bug has been marked as a duplicate of 125712 ***

Comment 4 Harald Hoyer 2004-07-29 13:59:40 UTC
/etc/resolv.conf should probably only be accessed through viresolv
like visudo or addnameserver delnameserver like adduser for /etc/passwd

Comment 5 Red Hat Bugzilla 2006-02-21 19:04:09 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.