Bug 1263215 - Fail to unpersist file if not using full path
Fail to unpersist file if not using full path
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node (Show other bugs)
3.5.4
x86_64 Linux
high Severity high
: ovirt-3.5.5
: 3.5.5
Assigned To: Fabian Deutsch
Virtualization Bugs
node
: ZStream
Depends On: 1259007
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-15 06:54 EDT by rhev-integ
Modified: 2016-02-10 14:17 EST (History)
7 users (show)

See Also:
Fixed In Version: ovirt-node-3.2.3-23 rhev-hypervisor7-7.1-20150917.0 rhev-hypervisor6-6.7-20150917.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1259007
Environment:
Last Closed: 2015-10-26 17:40:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 45795 master MERGED fs: Use the abspath to check persistence Never
oVirt gerrit 46161 ovirt-3.6 MERGED fs: Use the abspath to check persistence Never

  None (edit)
Comment 2 wanghui 2015-09-21 03:42:53 EDT
Test version:
rhev-hypervisor7-7.1-20150917.0
rhev-hypervisor6-6.7-20150917.0
ovirt-node-3.2.3-23

Test scenario1:
Test step:
1. Clean install rhevh
2. cd /etc/sysconfig/network-scripts/
3. touch test 
4. persist test
5. unpersist test

Test result:
1. unpersist test succeed.

Test secnario2:
Test step:
1. Clean install rhevh
2. cd /data
3. touch test11 
4. persist test11
5. unpersist test11

Test result:
1. #unpersist test11
Failed to unpersist "test11"
Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/ovirt/node/utils/fs/__init__.py", line 598, in unpersist
  File "/usr/lib/python2.6/site-packages/ovirt/node/utils/fs/__init__.py", line 650, in _unpersist_file
  File "/usr/lib/python2.6/site-packages/ovirt/node/utils/fs/__init__.py", line 610, in _cleanup_tree
OSError: [Errno 30] Read-only file system: '/config'
Cannot unpersist: test11
2. But actually unpersist is succeed. The /data/test11 is removed from /config/files.

There still has some issue when unpersist file is in /data. So change the status to assigned.
Comment 3 Fabian Deutsch 2015-09-21 05:16:17 EDT
The bug in comment 2 is a different bug, please file a separate bug for this.

This bug can be verified according to comment 2.
Comment 4 wanghui 2015-09-21 05:45:41 EDT
Verify this issue with scenario#1 in  comment#2.
Comment 6 errata-xmlrpc 2015-10-26 17:40:12 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1935.html

Note You need to log in before you can comment on or make changes to this bug.