Bug 1263224 - 'gluster v tier/attach-tier/detach-tier help' command shows the usage, and then throws 'Tier command failed' error message
'gluster v tier/attach-tier/detach-tier help' command shows the usage, and th...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Manikandan
bugs@gluster.org
: Reopened
Depends On:
Blocks: 1260923 1264738
  Show dependency treegraph
 
Reported: 2015-09-15 07:09 EDT by Manikandan
Modified: 2016-09-20 00:29 EDT (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1264738 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:37:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Manikandan 2015-09-15 07:09:52 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Manikandan 2015-09-15 07:15:42 EDT
(In reply to Manikandan from comment #0)
Description of problem:

Currently, 'gluster v tier help' command shows

gluster v tier help
Usage: volume tier <VOLNAME> status
volume tier <VOLNAME> attach [<replica COUNT>] <NEW-BRICK>...
volume tier <VOLNAME> detach <start|stop|status|commit|[force]>

Tier command failed.

 
 
Version-Release number of selected component (if applicable): 

 How reproducible:
 

Steps to Reproduce:
Issue 'gluster v tier/attach-tier/detach-tier help' command

Actual results:
Usage is shown with a error message

Expected results:
Error message should not be thrown after showing the usage.
 
 
Additional info:
Comment 2 Vijay Bellur 2015-09-15 07:37:52 EDT
REVIEW: http://review.gluster.org/12181 (tier/cli : adding a check for gluster v tier help command) posted (#1) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)
Comment 3 Niels de Vos 2016-06-16 09:37:36 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.