Bug 1263269 - [RFE] Ability to edit storage domain paths
[RFE] Ability to edit storage domain paths
Status: CLOSED DUPLICATE of bug 977379
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.5.3
All Linux
medium Severity medium
: ---
: 3.6.0
Assigned To: Allon Mureinik
storage
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-15 09:20 EDT by Ulhas Surse
Modified: 2016-02-10 15:27 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-16 11:28:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ulhas Surse 2015-09-15 09:20:37 EDT
3. What is the nature and description of the request?  
       We want to be able to able to edit storage domain paths for already created storage domains in RHEV.

    4. Why does the customer need this? (List the business requirements here)  
       To be able to restructure storage configurations in the back end, it might be necessary to change which paths servers use to access the storage. As this is not currently possible in RHEV there is a risk that a situation appears when some paths to the storage are no longer accessible, which is acceptable for the already current hosts, since they simply use the other working paths. However, it makes adding new hosts impossible, since they verify all paths to the storage before being added to the cluster.
It will also present a problem if a new path to the storage is added, since that path cannot be added to the storage domain in RHEV.

    5. How would the customer like to achieve this? (List the functional requirements here)  
       While editing a storage domain, it should be possible to uncheck the paths that are not longer available, as well as scanning the storage system for new paths and add those.

    6. For each functional requirement listed, specify how Red Hat and the customer can test to confirm the requirement is successfully implemented.  
       Yes

    7. Is there already an existing RFE upstream or in Red Hat Bugzilla?  
       No

    8. Does the customer have any specific timeline dependencies and which release would they like to target (i.e. RHEL5, RHEL6)?  
       No

    9. Is the sales team involved in this request and do they have any additional input?  
       No

    10. List any affected packages or components.  
        RHEVM

    11. Would the customer be able to assist in testing this functionality if implemented? 
        Unsure, but hopefully.
Comment 2 Allon Mureinik 2015-09-16 11:28:36 EDT
This is already available via REST-API (see http://www.ovirt.org/Features/Manage_Storage_Connections).

The only missing part is GUI for managing block connections (see bug 977379).

*** This bug has been marked as a duplicate of bug 977379 ***

Note You need to log in before you can comment on or make changes to this bug.