Bug 1263293 - [RFE] Using MongoDB aggregation pipeline framework for statistics queries instead of map-reduce
[RFE] Using MongoDB aggregation pipeline framework for statistics queries ins...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-ceilometer (Show other bugs)
8.0 (Liberty)
Unspecified Unspecified
medium Severity low
: beta
: 8.0 (Liberty)
Assigned To: Eoghan Glynn
Yurii Prokulevych
https://blueprints.launchpad.net/ceil...
upstream_milestone_liberty-2 upstream...
: FutureFeature, OtherQA
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-15 09:48 EDT by Eoghan Glynn
Modified: 2016-04-07 17:08 EDT (History)
4 users (show)

See Also:
Fixed In Version: openstack-ceilometer-5.0.0-1.el7ost
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 17:08:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eoghan Glynn 2015-09-15 09:48:17 EDT
In icehouse, usuage of the MongoDB aggregation pipeline framework for statistics queries was dropped in favor of a plain ol' map-reduce, due to ungraceful out-of-memory conditions arising out of the sorting/filtering logic in the 2.2-era MongoDB aggregation pipeline.

Since these issues have been apparently resolved in MongoDB 2.6, the aggregation pipeline has been reinstated.

This needs to be verified by QE to ensure that the out-of-memory problems are indeed resolved.
Comment 4 Yurii Prokulevych 2016-03-21 06:31:52 EDT
Tried statistics call with 1 million of samples.
Packages:
ceilometer*-5.0.2-2.el7ost.noarch
mongodb*-2.6.11-1.el7ost.x86_64
Comment 6 errata-xmlrpc 2016-04-07 17:08:43 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0603.html

Note You need to log in before you can comment on or make changes to this bug.