Bug 1263297 - write_riemann plugin is missing
write_riemann plugin is missing
Status: CLOSED NOTABUG
Product: Fedora EPEL
Classification: Fedora
Component: collectd (Show other bugs)
epel7
x86_64 Other
unspecified Severity unspecified
: ---
: ---
Assigned To: Ruben Kerkhof
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-15 09:54 EDT by Deyan Dobrinov
Modified: 2015-09-15 12:11 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-15 10:14:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Deyan Dobrinov 2015-09-15 09:54:52 EDT
Description of problem:
One of the available plugins in collectd is missing in the currently available rpm package - https://dl.fedoraproject.org/pub/epel/7/x86_64/c/collectd-5.5.0-2.el7.x86_64.rpm

If you open the collectd plugin documentation you will see that this plugin should be packaged with collectd since version 5.3.0. (https://collectd.org/wiki/index.php/Table_of_Plugins)

Version-Release number of selected component (if applicable):
collectd-5.5.0-2.el7.x86_64.rpm

How reproducible:


Steps to Reproduce:
1. Install collectd
2. Configure it to work with Riemann
3. A message will be available in the logs that the plugin is missing.
4. You won't be able to find write_rieman.so next to the rest of the plugins (/usr/lib64/collectd)

or

1. Download the .rpm
2. rpm -q -filesbypkg -p collectd-5.5.0-2.el7.x86_64.rpm | grep write_riemann.so

Actual results:
/usr/lib64/collectd/write_riemann.so is missing

Expected results:
/usr/lib64/collectd/write_riemann.so is present

Additional info:
Comment 1 Deyan Dobrinov 2015-09-15 10:14:34 EDT
I just found why it is missing:
https://dl.fedoraproject.org/pub/epel/7/x86_64/c/collectd-write_riemann-5.5.0-2.el7.x86_64.rpm

Sorry! :)
Comment 2 Ruben Kerkhof 2015-09-15 12:11:15 EDT
Yes, you indeed need to install collectd-write_riemann.

Note You need to log in before you can comment on or make changes to this bug.