Bug 1263312 - Using the org switcher prior to starting a new deployment can mess up the installer UI, and hide the step indicator
Using the org switcher prior to starting a new deployment can mess up the ins...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: WebUI (Show other bugs)
1.0
Unspecified Unspecified
high Severity high
: TP2
: 1.0
Assigned To: jmagen@redhat.com
Dave Johnson
: Triaged
Depends On:
Blocks: rhci-sprint-10 rhci-sprint-11 rhci-sprint-12
  Show dependency treegraph
 
Reported: 2015-09-15 10:12 EDT by Matt Reid
Modified: 2016-10-03 15:28 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-03 15:28:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Step indicator is off-screen (41.07 KB, image/png)
2015-09-15 10:13 EDT, Matt Reid
no flags Details

  None (edit)
Description Matt Reid 2015-09-15 10:12:24 EDT
Description of problem:
It's possible to get the UI hung up on itself, and be unable to complete the deployment configuration, since the step indicator is buried underneath the navigation and off screen.

Version-Release number of selected component (if applicable):
Tech Preview + Sat 6.1.1

How reproducible:
pretty consistently

Steps to Reproduce:
1. Adjust the org once or twice between Default Organization and Any Organization
2. Click on RHCI Installer > Deployments
3. Click New Deployment
4. Click Select

Actual results:
UI loads weird, and you can't see the step indicator

Expected results:
UI to load normally

Additional info:
This has happened across multiple installs doing the same steps with the same ISO
Comment 1 Matt Reid 2015-09-15 10:13:00 EDT
Created attachment 1073691 [details]
Step indicator is off-screen
Comment 2 jmagen@redhat.com 2015-10-15 02:50:01 EDT
Matt, I'm not able to duplicate this. 
I'm using the dev setup, so not sure if that is it.
Comment 3 John Matthews 2015-10-15 13:55:40 EDT
I also tried on a devel env using latest fusor code and was not able to replicate.
Comment 4 jmagen@redhat.com 2016-01-13 08:03:21 EST
Still not able to duplicate. Can we close this BZ?
Comment 5 Matt Reid 2016-01-13 11:21:11 EST
I don't have access to a live environment to check, but if neither of you have been able to reproduce yet, might be safe to close. I can always reopen if we hit it again in the next walkthrough. At the time, all of our deployments exhibited that behavior, even after reinstalling everything from the same source.
Comment 6 Antonin Pagac 2016-02-01 07:52:54 EST
Unable to reproduce, marking as verified.

RHCI-6.0-RHEL-7-20160128.1-RHCI-x86_64-dvd1.iso
RHCIOOO-7-RHEL-7-20160127.0-RHCIOOO-x86_64-dvd1.iso

Note You need to log in before you can comment on or make changes to this bug.