Bug 1263317 - machine type capabilities are missing the canonical names of default types
machine type capabilities are missing the canonical names of default types
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libvirt (Show other bugs)
7.1
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Jiri Denemark
Virtualization Bugs
: DevelBlocker, Regression, TestBlocker, ZStream
Depends On: 1229666
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-15 10:15 EDT by Jan Kurik
Modified: 2015-12-01 10:04 EST (History)
17 users (show)

See Also:
Fixed In Version: libvirt-1.2.8-16.el7_1.5
Doc Type: Bug Fix
Doc Text:
Due to the fact that the libvirt library uses different ways of checking machine types supported by the qemu-kvm module in Red Hat Enterprise Linux 6 and in Red Hat Enterprise Linux 7, libvirt previously advertized both the canonical machine type name and its alias as supported in Red Hat Enterprise Linux 6, but only the alias in Red Hat Enterprise Linux 7. With this update, libvirt requests the list of supported machine types from qemu-kvm and updates the list to always contain both the canonical name and its alias. While the methods to retrieve supported machine types from qemu-kvm differ, both canonical machine type names and their aliases are now advertized as supported in both versions of Red Hat Enterprise Linux.
Story Points: ---
Clone Of: 1229666
Environment:
Last Closed: 2015-11-04 10:49:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kurik 2015-09-15 10:15:14 EDT
This bug has been copied from bug #1229666 and has been proposed
to be backported to 7.1 z-stream (EUS).
Comment 8 zhenfeng wang 2015-09-25 01:22:49 EDT
Reproduce this bug with libvirt-1.2.8-16.el7_1.4.x86_64, couldn't see the default machine type in the capabilities, could only see the canonical machine type

# /usr/libexec/qemu-kvm -machine help
Supported machines are:
pc                   RHEL 7.1.0 PC (i440FX + PIIX, 1996) (alias of pc-i440fx-rhel7.1.0)
pc-i440fx-rhel7.1.0  RHEL 7.1.0 PC (i440FX + PIIX, 1996) (default)
pc-i440fx-rhel7.0.0  RHEL 7.0.0 PC (i440FX + PIIX, 1996)


#virsh capabilities
<guest>
    <os_type>hvm</os_type>
    <arch name='x86_64'>
      <wordsize>64</wordsize>
      <emulator>/usr/libexec/qemu-kvm</emulator>
      <machine canonical='pc-i440fx-rhel7.1.0' maxCpus='240'>pc</machine>
      <machine maxCpus='240'>rhel6.6.0</machine>
      <machine maxCpus='240'>pc-q35-rhel7.0.0</machine>


Verify this bug with libvirt-1.2.8-16.el7_1.5.x86_64, could see the default machine type in the capabilities

pkginfo
qemu-kvm-rhev-2.1.2-23.el7_1.9.x86_64
libvirt-1.2.8-16.el7_1.5.x86_64

steps
# /usr/libexec/qemu-kvm -machine help
Supported machines are:
pc                   RHEL 7.1.0 PC (i440FX + PIIX, 1996) (alias of pc-i440fx-rhel7.1.0)
pc-i440fx-rhel7.1.0  RHEL 7.1.0 PC (i440FX + PIIX, 1996) (default)
pc-i440fx-rhel7.0.0  RHEL 7.0.0 PC (i440FX + PIIX, 1996)
rhel6.6.0            RHEL 6.6.0 PC

#virsh capabilities
--
  <guest>
    <os_type>hvm</os_type>
    <arch name='x86_64'>
      <wordsize>64</wordsize>
      <emulator>/usr/libexec/qemu-kvm</emulator>
      <machine maxCpus='240'>pc-i440fx-rhel7.1.0</machine>
      <machine canonical='pc-i440fx-rhel7.1.0' maxCpus='240'>pc</machine>
      <machine maxCpus='240'>rhel6.6.0</machine>
      <machine maxCpus='240'>pc-q35-rhel7.0.0</machine>

According to the upper steps, mark this bug verified
Comment 10 errata-xmlrpc 2015-11-04 10:49:55 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1969.html

Note You need to log in before you can comment on or make changes to this bug.