Bug 1263323 - Add new host, error message not shown
Add new host, error message not shown
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.6.0
All All
unspecified Severity medium
: ovirt-3.6.1
: 3.6.0
Assigned To: Alexander Wels
Lukas Svaty
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-15 10:27 EDT by Lukas Svaty
Modified: 2016-04-19 21:31 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-19 21:31:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of add host. (49.54 KB, image/png)
2015-09-15 10:27 EDT, Lukas Svaty
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 46630 master MERGED webadmin: new host provider error message Never
oVirt gerrit 46723 ovirt-engine-3.6 MERGED webadmin: new host provider error message Never

  None (edit)
Description Lukas Svaty 2015-09-15 10:27:40 EDT
Created attachment 1073705 [details]
Screenshot of add host.

Description of problem:
When adding new host, and only name of the host is filled. No address, and foreman/satellite checkbox is enabled after clicking OK no error message is displayed, but host is not added. General tab is in red square which is allright but does not show any message on mouseover. See screenshot.

Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. Add host
2. Check foreman/satellite checkbox and dont fill anything else.
3. Fill name
4. Press OK

Actual results:
No error message.

Expected results:
Appropriate error message telling admin to add foreman/satellite provider or address of host.

Additional info:
Screenshot
Comment 1 Alexander Wels 2015-09-21 15:57:01 EDT
I guess the problem is that the address field is disabled? The ..... underline of the 'address' label indicates that the problem is there, and in fact if you hover over the label it gives you a tooltip saying it can't be empty, however its disabled. I am just trying to make sure I understand the actual issue here.

Can someone enlighten me on the exact issue?
Comment 2 Lukas Svaty 2015-09-22 04:44:04 EDT
Didn't even see the underlined address.
I would say there are two issues now.

1. Underlining address is not visible enough. Should be probably marked with the red rectangle to be more visible.

2. Tooltip on hover over underlined address is saying 'This field can't be empty'. However whem Foreman/Satellite is enabled 'Adress' field is not accessible so the error message should rather be something like select Foreman/Satellite provider.
Comment 3 Alexander Wels 2015-09-22 11:08:04 EDT
1. Well the label underlining is the new way of marking errors. If you have issues with that, feel free to bring up the issue with the UXD team.

2. I am trying to determine what the proper solution should be. I can definitely change the message in case the foreman checkbox is checked. But are we sure that is the correct thing to do?

@Oved
Can you give some guidance on what the correct behavior should be, before I make any changes.
Comment 4 Oved Ourfali 2015-09-22 11:52:21 EDT
If a provider checkbox is checked, you must select a provider, an option for discovery or existing hosts, and the discovered or the existing host. 

If you don't select any of those, you should have red marker as we have in other cases. 

Is that okay, or you need additional information?
Comment 5 Lukas Svaty 2015-11-26 06:54:54 EST
verified in rhevm-webadmin-portal-3.6.1-0.2.el6.noarch

Note You need to log in before you can comment on or make changes to this bug.