Bug 1263337 - IPA Restore failed with installed KRA
IPA Restore failed with installed KRA
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: IPA Maintainers
Namita Soman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-15 10:56 EDT by Petr Vobornik
Modified: 2015-11-19 07:06 EST (History)
5 users (show)

See Also:
Fixed In Version: ipa-4.2.0-12.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 07:06:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
console output with verification steps (12.00 KB, text/plain)
2015-09-30 02:58 EDT, Kaleem
no flags Details

  None (edit)
Description Petr Vobornik 2015-09-15 10:56:11 EDT
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/freeipa/ticket/5297

Steps to reproduce:
1. install IPA
1. install KRA
1. backup
1. uninstall IPA
1. restore


Journal output
{{{
systemd[1]: Starting PKI Tomcat Server pki-tomcat...
pkidaemon[31532]: WARNING:  Symbolic link '/var/lib/pki/pki-tomcat/kra/logs' does NOT exist!
pkidaemon[31532]: INFO:  Attempting to create '/var/lib/pki/pki-tomcat/kra/logs' -> '/var/log/pki/pki-tomcat/kra' . . .
pkidaemon[31532]: ERROR:  Failed making '/var/lib/pki/pki-tomcat/kra/logs' -> '/var/log/pki/pki-tomcat/kra' since target '/var/log/pki/pki-tomcat/kra' does NOT exist!
systemd[1]: pki-tomcatd@pki-tomcat.service: control process exited, code=exited status=1
systemd[1]: Failed to start PKI Tomcat Server pki-tomcat.
systemd[1]: Unit pki-tomcatd@pki-tomcat.service entered failed state.
systemd[1]: pki-tomcatd@pki-tomcat.service failed.
systemd[1]: Reached target PKI Tomcat Server.
}}}
Comment 4 Kaleem 2015-09-30 02:58 EDT
Created attachment 1078544 [details]
console output with verification steps

Verified.

Please find the attached verification logs.
Comment 5 errata-xmlrpc 2015-11-19 07:06:38 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2362.html

Note You need to log in before you can comment on or make changes to this bug.