Bug 1263342 - Subscription table doesn't show quantities of -1 as Unlimited
Subscription table doesn't show quantities of -1 as Unlimited
Status: CLOSED ERRATA
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: WebUI (Show other bugs)
1.0
Unspecified Unspecified
high Severity high
: ga
: 1.0
Assigned To: jmagen@redhat.com
Antonin Pagac
: Triaged
Depends On:
Blocks: rhci-sprint-16
  Show dependency treegraph
 
Reported: 2015-09-15 11:14 EDT by Matt Reid
Modified: 2016-09-13 12:22 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-13 12:22:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Reid 2015-09-15 11:14:19 EDT
Description of problem:
The subscription table on step 4C looks like it shows the raw information we get from the API call, which I believe uses a -1 to indicate Unlimited. We should catch those and replace -1 with Unlimited to make more sense for end users.

Version-Release number of selected component (if applicable):
Tech Preview


Additional info:
Comment 1 jmagen@redhat.com 2015-10-15 02:52:33 EDT
Matt, please explain more. If subscriptions available are "4 of 50" are you saying it shows "4 of -1" when it should be "4 of unlimited"
Comment 3 jmagen@redhat.com 2015-11-17 07:26:50 EST
fixed
https://github.com/fusor/fusor/pull/471
Comment 4 Thom Carlin 2016-02-15 06:12:55 EST
In TP2 RC9, displays: Consumed 0 out of Unlimited in Content > Red Hat Subscription
Comment 5 Thom Carlin 2016-02-15 06:58:36 EST
4C shows: x out of y under Available
Comment 9 jmagen@redhat.com 2016-04-27 07:24:30 EDT
This was fixed in November 2015 by 
https://github.com/fusor/fusor/commit/0c81cb11ae28dd7fa1f1235a3dd1ee1a2a4702a7

Please verify.
Comment 11 jmagen@redhat.com 2016-07-05 10:02:50 EDT
Antonin, I created a new PR https://github.com/fusor/fusor/pull/1003 which should fix the problem. Please check.
Comment 12 John Matthews 2016-07-18 17:12:05 EDT
QCI-1.2-RHEL-7-20160718.t.0
Comment 17 Antonin Pagac 2016-08-11 06:08:45 EDT
Verified in 20160809.t.1
Comment 19 errata-xmlrpc 2016-09-13 12:22:02 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1862

Note You need to log in before you can comment on or make changes to this bug.