Bug 1263363 - Exception AttributeError: "'NoneType' object has no attribute 'udev_unref'" in <bound method Context.__del__ of <pyudev.core.Context object at 0x16ef890>> ignored
Exception AttributeError: "'NoneType' object has no attribute 'udev_unref'" i...
Status: CLOSED DUPLICATE of bug 1252833
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda (Show other bugs)
7.2
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Anaconda Maintenance Team
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-15 12:05 EDT by Alexander Todorov
Modified: 2017-05-15 08:35 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-15 12:07:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexander Todorov 2015-09-15 12:05:43 EDT
Description of problem:

Jenkins reports the following error below the test results, although everything seems to pass:

Exception AttributeError: "'NoneType' object has no attribute 'udev_unref'" in <bound method Context.__del__ of <pyudev.core.Context object at 0x16ef890>> ignored


I'm not sure if this is expected or we're missing a possible failure here.
Comment 1 David Shea 2015-09-15 12:07:29 EDT

*** This bug has been marked as a duplicate of bug 1252833 ***
Comment 2 jack 2015-12-01 19:57:28 EST
(In reply to David Shea from comment #1)
> 
> *** This bug has been marked as a duplicate of bug 1252833 ***

Have this bug been solved ?
Comment 3 David Shea 2015-12-02 08:46:42 EST
(In reply to jack from comment #2)
> (In reply to David Shea from comment #1)
> > 
> > *** This bug has been marked as a duplicate of bug 1252833 ***
> 
> Have this bug been solved ?

No, but the message can be safely ignored.
Comment 4 Matt Moldvan 2016-06-16 22:21:34 EDT
Getting this error as well as the last thing I see before a kickstart provision fails... unfortunately I'm unable to view the ticket that was marked as a duplicate.  Was hoping someone could share whatever the resolution for that one is to give me an idea of where to go?
Comment 5 Matt Moldvan 2016-06-16 22:39:07 EDT
Never mind, sorry... turned out to be completely unrelated to anaconda.
Comment 6 nickw1985 2016-07-13 22:42:16 EDT
(In reply to Matt Moldvan from comment #5)
> Never mind, sorry... turned out to be completely unrelated to anaconda.

Hi Matt Moldvan

This is driving me insane - any chance you can elaborate of how you resolved this issue?
Comment 7 Brian J. Murrell 2016-12-12 14:50:48 EST
(In reply to David Shea from comment #1)
> 
> *** This bug has been marked as a duplicate of bug 1252833 ***

Except that for the rest of us, bug 1252833 is not visible and so it doesn't help us that you closed this one as a duplicate of that one.
Comment 8 Gordon Messmer 2017-01-06 16:44:37 EST
I'm seeing this error message in 7.3.  One kickstart file works if I remove the "network" line.  However, I have another file that isn't fixed as readily, so I think there may be more than one bug.  I'm still tracking these down.
Comment 9 Samantha N. Bueno 2017-04-13 10:14:35 EDT
Apologies for the lack of response to everyone who has commented asking for more information. The issue, as noted above, has nothing to do with anaconda. This turned out to be a problem with the python-pyudev package and is being worked on presently.

Note You need to log in before you can comment on or make changes to this bug.