Bug 1263368 - option to show the window list on all monitors
option to show the window list on all monitors
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-shell-extensions (Show other bugs)
7.2
All Linux
unspecified Severity urgent
: rc
: ---
Assigned To: Florian Müllner
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-15 12:13 EDT by Jacob Hunt
Modified: 2015-11-19 02:21 EST (History)
3 users (show)

See Also:
Fixed In Version: gnome-shell-extensions-3.14.4-13.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 02:21:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 737486 None None None Never

  None (edit)
Description Jacob Hunt 2015-09-15 12:13:43 EDT
Description of problem:

Users with multiple monitors cannot have a window list that shows applications open on all of their monitors. This is a big usability issue for gnome-shell vs what is available in gnome 2.


Version-Release number of selected component (if applicable):

gnome-shell-extension-window-list-3.14.4-12.el7.noarch
Comment 7 Bohdan Milar 2015-09-22 13:17:09 EDT
Works now!

HW for test:
- ThinkPad T540p + external Samsung (HD) monitor connected via VGA (directly, no docking station).
- Internal display and external monitor were set as primary and secondary (no mirroring). Primary and secondary arranged horizontally first, then vertically.

Tested versions:
gnome-shell-3.14.4-29.el7.x86_64
gnome-shell-extension-window-list-3.14.4-14.el7.noarch

Tested archs:
- x86_64

Tested sessions:
- GNOME session
- GNOME Classic

Results:
- In the settings dialog for the Window List extension (gnome-shell-extension-prefs), there is a new checkbox "Show on all monitors".
- When the checkbox is checked, window list (bar/panel) with no window buttons (items) appears on secondary monitor.
- When a window is dragged from one display to the other, the relevant button disappears from the window list panel on source display and appears in the window list panel on destination display.
- In the "Switch system controls" list (ctrl+alt+tab), there are 2 items called "Window List".
Comment 8 Bohdan Milar 2015-09-23 04:46:21 EDT
Works also with 2 monitors connected to docking station and even in 3-display setup (internal notebook display + 2 external monitors).
Comment 9 errata-xmlrpc 2015-11-19 02:21:14 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2216.html

Note You need to log in before you can comment on or make changes to this bug.