Bug 1263371 - Can't install geany-plugins-* due to dependency resolution issue
Can't install geany-plugins-* due to dependency resolution issue
Status: CLOSED DUPLICATE of bug 1148627
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
22
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-15 12:31 EDT by Gavin Simpson
Modified: 2015-09-21 05:28 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-21 05:28:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gavin Simpson 2015-09-15 12:31:24 EDT
Description of problem:

It seems impossible to install all the geany-plugins-* packages because they claim to require geany-plugins-common-1.25-1 yet this version is available. Even when I install this pkg on it's own and retry to install geany-plugins-* dnf complains that geany-plugins-common-1.25-1 is required but none of the providers can install it:


Version-Release number of selected component (if applicable):

$ dnf --version
1.1.1
  Installed: dnf-0:1.1.1-2.fc22.noarch at 2015-09-10 14:36
  Built    : Fedora Project at 2015-09-08 12:24

  Installed: rpm-0:4.12.0.1-12.fc22.x86_64 at 2015-08-28 21:30
  Built    : Fedora Project at 2015-06-29 10:36


How reproducible:

Always

Steps to Reproduce:
1. Run sudo dnf install geany-plugins-*
2.
3.

Actual results:

[gavin@haul ~]$ sudo dnf install geany-plugins*
Last metadata expiration check performed 1:21:03 ago on Tue Sep 15 09:05:16 2015.
Error: package geany-plugins-geanyctags-1.25-1.fc22.x86_64 requires geany-plugins-common = 1.25-1.fc22, but none of the providers can be installed.
package geany-plugins-automark-1.25-1.fc22.x86_64 requires geany-plugins-common = 1.25-1.fc22, but none of the providers can be installed
(try to add '--allowerasing' to command line to replace conflicting packages)
[gavin@haul ~]$ dnf info geany-plugins-common
Last metadata expiration check performed 14 days, 0:58:12 ago on Tue Sep  1 09:28:12 2015.
Available Packages
Name        : geany-plugins-common
Arch        : x86_64
Epoch       : 0
Version     : 1.25
Release     : 1.fc22
Size        : 281 k
Repo        : updates
Summary     : Common files used by all geany plugins
URL         : http://plugins.geany.org/
License     : GPLv3+
Description : This package contains some common files which are used by every Geany plugin,
            : e.g. language translations.

[gavin@haul ~]$ sudo dnf install geany-plugins-common
Last metadata expiration check performed 1:21:18 ago on Tue Sep 15 09:05:16 2015.
Dependencies resolved.
================================================================================================================================================================================================================================================================================
 Package                                                                    Arch                                                         Version                                                            Repository                                                     Size
================================================================================================================================================================================================================================================================================
Installing:
 geany-plugins-common                                                       x86_64                                                       1.25-1.fc22                                                        updates                                                       281 k

Transaction Summary
================================================================================================================================================================================================================================================================================
Install  1 Package

Total download size: 281 k
Installed size: 1.1 M
Is this ok [y/N]: y
Downloading Packages:
geany-plugins-common-1.25-1.fc22.x86_64.rpm                                                                                                                                                                                                     757 kB/s | 281 kB     00:00    
--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Total                                                                                                                                                                                                                                           246 kB/s | 281 kB     00:01     
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Installing  : geany-plugins-common-1.25-1.fc22.x86_64                                                                                                                                                                                                                     1/1 
  Verifying   : geany-plugins-common-1.25-1.fc22.x86_64                                                                                                                                                                                                                     1/1 

Installed:
  geany-plugins-common.x86_64 1.25-1.fc22                                                                                                                                                                                                                                       

Complete!
[gavin@haul ~]$ sudo dnf install geany-plugins*
Last metadata expiration check performed 1:21:25 ago on Tue Sep 15 09:05:16 2015.
Package geany-plugins-common-1.25-1.fc22.x86_64 is already installed, skipping.
Error: package geany-plugins-overview-1.25-1.fc22.x86_64 requires geany-plugins-common = 1.25-1.fc22, but none of the providers can be installed.
package geany-plugins-projectorganizer-1.25-1.fc22.x86_64 requires geany-plugins-common = 1.25-1.fc22, but none of the providers can be installed
(try to add '--allowerasing' to command line to replace conflicting packages)

Expected results:

That all packages matching pattern geany-plugins-* are installed

Additional info:
Comment 1 Honza Silhan 2015-09-21 05:28:47 EDT
From the outputs:
`(try to add '--allowerasing' to command line to replace conflicting packages)`

If you try it you get some hints what needs to be removed in order to have them installed. I guess there are the package conflicts.

*** This bug has been marked as a duplicate of bug 1148627 ***

Note You need to log in before you can comment on or make changes to this bug.