Bug 126343 - Installer crashes after "Upgrade Examine" screen (trying to make LVM nodes?)
Installer crashes after "Upgrade Examine" screen (trying to make LVM nodes?)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-19 11:19 EDT by Don Waugaman
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-01 18:34:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Full dump of anaconda state (as near as I can tell) upon finding this error (142.08 KB, text/plain)
2004-06-19 11:21 EDT, Don Waugaman
no flags Details

  None (edit)
Description Don Waugaman 2004-06-19 11:19:50 EDT
Description of problem:
While performing an upgrade install of a Fedora Core 1 system to
Fedora Core 2, I select a partition to upgrade in the "Upgrade
Examine" screen. After clicking on the "next" button, the disks are
accessed briefly and then an exception occurs, with the notation to
take down the python exception information and report it on bugzilla.

Out of the ordinary:  Looking at the python exception information, it
appears to be trying to do something with LVM, which I do not use.  I
do, however, have one raid0 and one raid1 partition, the former on two
SCSI drives, the latter between two IDE drives.

However, it's all in the dump shown below.  (For that matter, I'm not
sure why all the "upgrading" messages come up - I haven't gotten
anywhere near package installation yet...)


Version-Release number of selected component (if applicable):
FC2 Installer

How reproducible:
every time

Steps to Reproduce:
1.  Perform an upgrade install on my system.
2.  Select a partition at the "upgrade examine" screen.
3.  Dump crash data to disk.

  
Actual results:
Python exception in the anaconda installer occurred.


Expected results:
Installation to continue to next screen (I don't know - package
selection, perhaps?)




Additional info:
Comment 1 Don Waugaman 2004-06-19 11:21:51 EDT
Created attachment 101260 [details]
Full dump of anaconda state (as near as I can tell) upon finding this error
Comment 2 Heiko Jakob 2004-06-23 12:40:45 EDT
This seems to be a duplicate of Bug #125405. But the #125405
summary/headline is miss leading. 
Comment 3 Don Waugaman 2004-06-24 12:51:33 EDT
It's apparently similar in effect, but not the same.

The exception dump in #125405 is similar early on, but there are some
key differences later.

We're more or less the same to this point:

File "/usr/lib/anaconda/dispatch.py", line 237, in moveStep
    rc = apply(func, self.bindArgs(args))

In this line, for bug #125405, 'func' is doMigrateFilesystems in
packages.py, while for this bug, 'func' is upgradeMountFilesystems
also in packages.py.

The other difference is that I haven't used lvm on this system, unlike
in #125405.

However, I noticed that my system has an empty /etc/lvmtab file, which
may be hosing things (it already creates some spurious output on
bootup).  I'll delete the file and try it again.
Comment 4 Don Waugaman 2004-06-25 12:54:51 EDT
My attempted fix didn't work, so I'll reopen this (I'm not sure how it
got closed... but what the heck).

Taking a look at the source code in the anaconda source rpm on CD #3,
it appears that the problem is that the call to
self.getEntryByMountPoint in fsset.py, line 1463 returns None into
root, which is later used in the line that raises the exception.  This
apparently happens because there is no "/" filesystem in self.entries
of the FileSystemSet object.  I can't see anywhere in fsset.py where
"/" is put into that object, but it looks like it's supposed to happen
in upgrade.py, and for some reason is not.
Comment 5 Jeremy Katz 2005-02-01 18:34:18 EST
This is fixed now

Note You need to log in before you can comment on or make changes to this bug.