Bug 1263432 - the RHN RHEL Channels 'rhel-x86_64-<VARIANT>-7-thirdparty-oracle-java-beta' map to a '7.1' version cert; should be '7.2 Beta'
the RHN RHEL Channels 'rhel-x86_64-<VARIANT>-7-thirdparty-oracle-java-beta' m...
Status: CLOSED DUPLICATE of bug 1241221
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager-migration-data (Show other bugs)
7.2
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: candlepin-bugs
John Sefler
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-15 14:47 EDT by John Sefler
Modified: 2015-09-17 18:56 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-17 11:11:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2015-09-15 14:47:34 EDT
Description of problem:
Since this package of subscription-manager-migration-data is targeted for RHEL7.2, the following beta channels should map to a product cert that contains a Version "7.2 Beta" value.  Instead they contain a Version "7.1" value.

rhel-x86_64-client-7-thirdparty-oracle-java-beta
rhel-x86_64-hpc-node-7-thirdparty-oracle-java-beta
rhel-x86_64-server-7-thirdparty-oracle-java-beta
rhel-x86_64-workstation-7-thirdparty-oracle-java-beta

Version-Release number of selected component (if applicable):
[root@jsefler-7 ~]# rpm -q subscription-manager-migration-data
subscription-manager-migration-data-2.0.23-1.el7.noarch


How reproducible:


Steps to Reproduce:

[root@jsefler-7 ~]# grep 7-thirdparty-oracle-java-beta /usr/share/rhsm/product/RHEL-7/channel-cert-mapping.txt
rhel-x86_64-client-7-thirdparty-oracle-java-beta: Client-x86_64-b441d47d167e-242.pem
rhel-x86_64-hpc-node-7-thirdparty-oracle-java-beta: ComputeNode-OracleJava-x86_64-9f9042b06588-243.pem
rhel-x86_64-server-7-thirdparty-oracle-java-beta: Server-x86_64-d661a269fe8c-240.pem
rhel-x86_64-workstation-7-thirdparty-oracle-java-beta: Workstation-x86_64-4e4ccd47a292-244.pem
[root@jsefler-7 ~]# 
[root@jsefler-7 ~]# rct cat-cert /usr/share/rhsm/product/RHEL-7/Client-x86_64-b441d47d167e-242.pem | tail -9
Product:
	ID: 242
	Name: Oracle Java (for RHEL Client)
	Version: 7.1           <=========== EXPECTED 7.2 Beta
	Arch: x86_64
	Tags: rhel-7-client
	Brand Type: 
	Brand Name: 

[root@jsefler-7 ~]# rct cat-cert /usr/share/rhsm/product/RHEL-7/ComputeNode-OracleJava-x86_64-9f9042b06588-243.pem | tail -9
Product:
	ID: 243
	Name: Oracle Java (for RHEL Compute Node)
	Version: 7.1 Beta           <=========== EXPECTED 7.2 Beta
	Arch: x86_64
	Tags: rhel-7-computenode-oraclejava,rhel-7-oraclejava
	Brand Type: 
	Brand Name: 

[root@jsefler-7 ~]# rct cat-cert /usr/share/rhsm/product/RHEL-7/Server-x86_64-d661a269fe8c-240.pem | tail -9
Product:
	ID: 240
	Name: Oracle Java (for RHEL Server)
	Version: 7.1           <=========== EXPECTED 7.2 Beta
	Arch: x86_64
	Tags: rhel-7-server
	Brand Type: 
	Brand Name: 

[root@jsefler-7 ~]# rct cat-cert /usr/share/rhsm/product/RHEL-7/Workstation-x86_64-4e4ccd47a292-244.pem | tail -9
Product:
	ID: 244
	Name: Oracle Java (for RHEL Workstation)
	Version: 7.1           <=========== EXPECTED 7.2 Beta
	Arch: x86_64
	Tags: rhel-7-workstation
	Brand Type: 
	Brand Name: 





Actual results:
above

Expected results:
For all four 7-thirdparty-oracle-java-beta channel-to-product cert mappings above, I expected the product cert versions to be "7.2 Beta"

Additional info:

The product Tags in the certs above also look suspicious to me.  They need to match the yum content sets from release engineering for thirdparty-oracle-java-beta.
Comment 1 John Sefler 2015-09-15 15:00:06 EDT
anthomas,
Also advise what the expected product tags should be.  I suspect they should be...

	Tags: rhel-7-client-oraclejava,rhel-7-oraclejava
	Tags: rhel-7-computenode-oraclejava,rhel-7-oraclejava
	Tags: rhel-7-server-oraclejava,rhel-7-oraclejava
	Tags: rhel-7-workstation-oraclejava,rhel-7-oraclejava
Comment 2 Andrew Thomas 2015-09-16 14:08:49 EDT
7.2 Beta certs were not created for Oraclejava. I have now created them and updated the mappings to point to the 7.2 Beta certificates.
Comment 3 Alex Wood 2015-09-17 11:02:34 EDT
In subscription-manager-migration-data-2.0.24-1
Comment 4 Alex Wood 2015-09-17 11:11:41 EDT

*** This bug has been marked as a duplicate of bug 1241221 ***
Comment 5 John Sefler 2015-09-17 18:56:41 EDT
Verifying Version....
[root@jsefler-7 ~]# rpm -q subscription-manager-migration-data
subscription-manager-migration-data-2.0.24-1.el7.noarch

[root@jsefler-7 ~]# grep 7-thirdparty-oracle-java-beta /usr/share/rhsm/product/RHEL-7/channel-cert-mapping.txt
rhel-x86_64-client-7-thirdparty-oracle-java-beta: Client-OracleJava-x86_64-25600658df2a-242.pem
rhel-x86_64-hpc-node-7-thirdparty-oracle-java-beta: ComputeNode-OracleJava-x86_64-50ea1afcb6eb-243.pem
rhel-x86_64-server-7-thirdparty-oracle-java-beta: Server-OracleJava-x86_64-d8e2d66e628d-240.pem
rhel-x86_64-workstation-7-thirdparty-oracle-java-beta: Workstation-OracleJava-x86_64-61a87a9a155d-244.pem
[root@jsefler-7 ~]# 
[root@jsefler-7 ~]# rct cat-cert /usr/share/rhsm/product/RHEL-7/Client-OracleJava-x86_64-25600658df2a-242.pem | tail -9
Product:
	ID: 242
	Name: Oracle Java (for RHEL Client)
	Version: 7.2 Beta                         <=== VERIFIED
	Arch: x86_64
	Tags: rhel-7-client-oraclejava,rhel-7-oraclejava  <=== VERIFIED
	Brand Type: 
	Brand Name: 

[root@jsefler-7 ~]# rct cat-cert /usr/share/rhsm/product/RHEL-7/ComputeNode-OracleJava-x86_64-50ea1afcb6eb-243.pem | tail -9
Product:
	ID: 243
	Name: Oracle Java (for RHEL Compute Node)
	Version: 7.2 Beta                                     <=== VERIFIED
	Arch: x86_64
	Tags: rhel-7-computenode-oraclejava,rhel-7-oraclejava <=== VERIFIED
	Brand Type: 
	Brand Name: 

[root@jsefler-7 ~]# rct cat-cert /usr/share/rhsm/product/RHEL-7/Server-OracleJava-x86_64-d8e2d66e628d-240.pem | tail -9
Product:
	ID: 240
	Name: Oracle Java (for RHEL Server)
	Version: 7.2 Beta                                <=== VERIFIED
	Arch: x86_64
	Tags: rhel-7-server-oraclejava,rhel-7-oraclejava <=== VERIFIED
	Brand Type: 
	Brand Name: 

[root@jsefler-7 ~]# rct cat-cert /usr/share/rhsm/product/RHEL-7/Workstation-OracleJava-x86_64-61a87a9a155d-244.pem | tail -9
Product:
	ID: 244
	Name: Oracle Java (for RHEL Workstation)
	Version: 7.2 Beta                                     <=== VERIFIED
	Arch: x86_64
	Tags: rhel-7-workstation-oraclejava,rhel-7-oraclejava <=== VERIFIED
	Brand Type: 
	Brand Name:

Note You need to log in before you can comment on or make changes to this bug.