Bug 1263443 - RBAC - When selecting Services>workloads + some functions in Infra Or Cloud to manage instance or VM: Cloud and Instructure Menue show up
RBAC - When selecting Services>workloads + some functions in Infra Or Cloud t...
Status: CLOSED DUPLICATE of bug 1247375
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.4.0
Unspecified Unspecified
unspecified Severity medium
: GA
: 5.5.0
Assigned To: Dan Clarizio
Dave Johnson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-15 15:21 EDT by Loic Avenel
Modified: 2015-11-11 15:24 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-15 17:51:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Loic Avenel 2015-09-15 15:21:22 EDT
Description of problem: RBAC - When selecting Services>workloads + some functions in Infra Or Cloud to manage instance or VM: Cloud and Instructure Menue show up
if you click on these menu, UI Crash

Version-Release number of selected component (if applicable):

5.4.2.0.20150820153254_83e434d 

How reproducible:

Always

Steps to Reproduce:
1. Create user with limited roles with access to Services>Workload
2. Add in Instructure>Virtual Machines>VM Access Rules>Operate>Edit Tags for example to set some possible action on the workloads
3. Log as the user

Actual results:

Infrastructure Menu show up with Request sub menu, clicking on Infrastructure will crash the UI
Same apply to Cloud but in this case there is only the Cloud Menu with no submenu


Expected results:

Infrastructure & Cloud Menu should be hidden like in 3.1


Additional info:
Comment 2 Harpreet Kataria 2015-09-15 17:51:28 EDT

*** This bug has been marked as a duplicate of bug 1247375 ***

Note You need to log in before you can comment on or make changes to this bug.