Bug 1263498 - 32-bit Cloud image missing for 23 Beta RC1
32-bit Cloud image missing for 23 Beta RC1
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
23
All All
unspecified Severity high
: ---
: ---
Assigned To: Václav Pavlín
Fedora Extras Quality Assurance
RejectedBlocker
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-15 21:30 EDT by Adam Williamson
Modified: 2015-11-04 06:36 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-04 06:36:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2015-09-15 21:30:02 EDT
Filing this so we can get a definitive decision.

There's some kind of problem with composing 32-bit Cloud images ATM. So 23 Beta RC1 has no 32-bit Cloud base image. It is not *entirely* clear to either QA or releng whether this image is currently considered release-blocking, even after reference to:

https://fedorahosted.org/cloud/ticket/106
https://fedorahosted.org/cloud/ticket/118
https://fedoraproject.org/wiki/Fedora_Program_Management/ReleaseBlocking/Fedora23

so I'm filing this ticket and proposing it as a Beta blocker in hopes the appropriate folks will review it and we can get a solid decision (and, ideally, have this clarified in the doc).
Comment 1 Kevin Fenzi 2015-09-16 18:03:16 EDT
It seems the issue is that the 32bit image runs out of space downloading the install.img while it's in dracut. Why this only happens on the 32bit image is unknown. 

Increasing the memory of the instance used to generate the image works around the problem. 

We changed this in: 

http://infrastructure.fedoraproject.org/cgit/ansible.git/commit/?id=f0fb0726f700d2d0f3eb5c3d935cc3955fa2b93b

(and tweaked in the following 2 commits). 

Resubmitting the failed cloud build now gives: 

http://koji.fedoraproject.org/koji/taskinfo?taskID=11113816

(where both x86_64 and i686 finish normally)
Comment 2 Adam Williamson 2015-09-17 12:36:48 EDT
Discussed at 2015-09-17 Fedora 23 Beta Go/No-Go meeting, acting as a blocker review meeting: https://meetbot-raw.fedoraproject.org/teams/f23_beta_go_no-go_meeting/f23_beta_go_no-go_meeting.2015-09-17-16.00.log.txt . Rejected as a blocker: the question of whether 32-bit Cloud images are considered release blocking for 23 is very unclear, it never seems to have been put to a clear up/down vote of Cloud WG or FESCo, all we have to go on are inferrals from what was written in various tickets and wiki pages at various times when wider votes were held.

So we err on the side of considering it non-blocker for now, and the issue will be taken to FESCo for a clear up/down vote before Final.

Note, though, that the images *have* now been built for RC1, and since we have them, they'll be included in the Beta release. Marking 'ON_QA' as they have not yet been moved into the RC1 tree (AFAIK).

Note You need to log in before you can comment on or make changes to this bug.