Bug 126351 - Bad ethereal-gnome dependencies (still requires gtk1)
Bad ethereal-gnome dependencies (still requires gtk1)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ethereal (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-19 17:07 EDT by John Thacker
Modified: 2015-03-04 20:14 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-20 20:23:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Thacker 2004-06-19 17:07:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.7)
Gecko/20040615 Firefox/0.9

Description of problem:
ethereal-gnome was switched a while back to compile with gtk2, which
is good.  However, the .spec file still has Requires: gtk+ >= 1.2,
which is bad.  The program no longer requires gtk+ at all now, so the
dependency needs to be removed.  This is a problem for anyone who
doesn't want gtk1 installed, but wants ethereal-gnome.  Inaccurate
dependencies are also just Bad Things.

Version-Release number of selected component (if applicable):
ethereal-gnome-0.10.3-2.2

How reproducible:
Always

Steps to Reproduce:
1. rpm -q --requires ethereal-gnome | grep gtk+

Alternately,
1. rpm -e --test gtk+

Or try to install ethereal-gnome without gtk+ installed
    

Actual Results:  ethereal-gnome explicitly depends on gtk1

Expected Results:  ethereal-gnome should only depend on gtk2, which
rpmbuild calculates (correctly) automatically.

Additional info:
Comment 1 John Thacker 2004-06-20 20:23:04 EDT
Thanks, that was fast.  Fixed in development.  Closing

Note You need to log in before you can comment on or make changes to this bug.