Bug 1263553 - Warning when SourceURL is on https://bitbucket.org (HTTP Error 403)
Warning when SourceURL is on https://bitbucket.org (HTTP Error 403)
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rpmlint (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-16 03:22 EDT by maarten
Modified: 2015-10-05 17:53 EDT (History)
5 users (show)

See Also:
Fixed In Version: rpmlint-1.8-2.fc23 rpmlint-1.8-2.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-03 13:33:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description maarten 2015-09-16 03:22:36 EDT
When a source url comes from https://bitbucket.org, rpmlint issues a HTTP Error 403 warning.

My patch to python-llfuse (available at https://bugzilla.redhat.com/show_bug.cgi?id=1256161#c4) exposes the problem.

Output of rpmlint is:
$ rpmlint ~/pkgs_fedora_project/python-llfuse/python-llfuse.spec ~/rpmbuild/RPMS/x86_64/python*
/home/build/pkgs_fedora_project/python-llfuse/python-llfuse.spec: W: invalid-url Source0: https://bitbucket.org/nikratio/python-llfuse/downloads/llfuse-0.41.1.tar.bz2 HTTP Error 403: Forbidden
3 packages and 1 specfiles checked; 0 errors, 1 warnings.
Comment 1 Ville Skyttä 2015-09-16 07:40:40 EDT
That's Amazon S3 returning 403 for HEAD requests. For details, see

$ curl -vIL https://bitbucket.org/nikratio/python-llfuse/downloads/llfuse-0.41.1.tar.bz2

rpmlint (upstream) issuing the warning is the expected behavior. But looks like there is an intent to filter this for bitbucket URLs in Fedora's rpmlint config, and it doesn't work because of a missing period:

$ grep bitbucket /usr/share/rpmlint/config
addFilter("invalid-url .*\bitbucket\.org/.*HTTP Error 403")

That should read:

addFilter("invalid-url .*\.bitbucket\.org/.*HTTP Error 403")
Comment 2 Ville Skyttä 2015-09-16 07:43:06 EDT
(In reply to Ville Skyttä from comment #1)
> That should read:

Scratch that, the issue is an extra \, not a missing period. So it should read:

addFilter("invalid-url .*bitbucket\.org/.*HTTP Error 403")

...or:

addFilter("invalid-url .*/bitbucket\.org/.*HTTP Error 403")
Comment 3 Fedora Update System 2015-09-28 11:04:14 EDT
rpmlint-1.8-2.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-b00be42cfd
Comment 4 Fedora Update System 2015-09-28 11:04:14 EDT
rpmlint-1.8-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-959308d20b
Comment 5 Fedora Update System 2015-09-29 02:22:01 EDT
rpmlint-1.8-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update rpmlint'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-959308d20b
Comment 6 Fedora Update System 2015-10-01 23:48:37 EDT
rpmlint-1.8-2.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update rpmlint'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-b00be42cfd
Comment 7 Fedora Update System 2015-10-03 13:33:26 EDT
rpmlint-1.8-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2015-10-05 17:53:41 EDT
rpmlint-1.8-2.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.