This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 126356 - 'linux rescue' fails to unmount the cd after booting
'linux rescue' fails to unmount the cd after booting
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
1
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-19 20:56 EDT by Ben Smith
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-21 14:07:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ben Smith 2004-06-19 20:56:41 EDT
Description of problem:
On systems with <192MB RAM, specifically 128MB, after getting to a
shell prompt from booting 'linux rescue', the cdrom is still mounted
and cannot be unmounted.  The cdrom is unmounted fine on similar
systems with >=192MB RAM.

Version-Release number of selected component (if applicable):
anaconda-9.2-2.i386.rpm

How reproducible:
very

Steps to Reproduce:
1. Boot from install cd;  select 'linux rescue'
2. Go through the steps to find/mount your partition
3. At the prompt, issue 'df' and notice that /mnt/source is still mounted
4. Issue 'ls /tmp/cdrom' and notice that the device no longer exists
5. Issue 'umount /mnt/source' or 'umount /tmp/cdrom' and it fails. 
6. Try 'umount -f' 'umount -n' 'umount -d' 'umount -l', all fail.
 
Actual results:
Unable to unmount cdrom drive, although it seems no longer in use.

Expected results:
CD should be unmounted automatically.

Additional info:
I will test on FC2 as well as narrowing down the exact amount of
memory needed.
Comment 1 Ben Smith 2004-06-19 21:27:00 EDT
This is as close as I was able to narrow it down:

It works if you have 130 Megs of RAM (linux rescue mem=130m).
It doesn't work if you have 128 Megs.
Comment 2 Jeremy Katz 2004-06-21 14:07:10 EDT
This is due to the fact that the rescue image runs off of the CD.  If
you have "sufficient" RAM (and our marker for this is at > 128 megs),
then we copy the image into RAM and run from there instead.

Note You need to log in before you can comment on or make changes to this bug.