Bug 1263561 - vlan tag removed in promiscuous mode with kernel 3.x and 4.x. working version is 2.6.36
vlan tag removed in promiscuous mode with kernel 3.x and 4.x. working version...
Status: CLOSED DUPLICATE of bug 1264316
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i386 Linux
unspecified Severity high
: rc
: ---
Assigned To: Red Hat Kernel Manager
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-16 03:36 EDT by Anitha
Modified: 2015-09-22 08:16 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-22 08:16:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vlan tag removed in promiscuous mode with kernel 3.x and 4.x. working version is 2.6.36 (59.86 KB, application/octet-stream)
2015-09-16 03:36 EDT, Anitha
no flags Details

  None (edit)
Description Anitha 2015-09-16 03:36:16 EDT
Created attachment 1073910 [details]
vlan tag removed in promiscuous mode with kernel 3.x and 4.x. working version is 2.6.36

Description of problem:
VLAN tagged packets are not received in application/program and Linux is stripping vlan tag and send to our program. with kernel 2.6.36 version, the vlan tagging works. below are the tried out version. we do not see any working version of vlan tagging in 3.x and 4.x. 

 kernel-2.6.32-431.el6.i686 - passed 
 kernel-2.6.32-504.16.2.el6.i686 -passed
 kernel-2.6.32-504.23.4.el6.i686 -not working
 kernel-2.6.32-504.30.3.el6.i686 - not working
 kernel-2.6.32-573.3.1.el6.i686 -not working
 Linux centos-6.5 2.6.36 -passed
 Linux centos-6.5 3.5.0 - not working
 Linux centos 4.2.0 -- not working

 as mentioned in search forum, we have tried to turn on/off rx-vlan-filter and offload setting, but we could not change it, as it is denoted as [fixed].

 to narrow down whether it is driver issue, with pcnet32 driver with failure kernel, eventhough rx-vlan-filter is off as below, still facing issue. so independent of driver, Kernel version differs in working and failure cases. 

 [root@localhost drivers]# ethtool -k eth5 | grep vlan
  rx-vlan-offload: off [fixed]
  tx-vlan-offload: off [fixed]
  rx-vlan-filter: off [fixed]
  vlan-challenged: off [fixed]

Version-Release number of selected component (if applicable):
tried in 3.0.4/3.1.0.2/3.2.4.2 and 4.2.0

How reproducible:
always with failure version

Steps to Reproduce:
1.ping vlan packets from external device to application configured vlan runs in Linux.
2.vlan tagging is removed in Linux and sent to application.


Actual results:
vlan tag is stripped out in promiscuous mode in Linux.

Expected results:
vlan tag should not be stripped out in promiscuous mode in Linux as a receiver.

Additional info:
attaching working logs where packet number 157 and 158 denotes, the vlan tagging is sent and received properly in Linux. with failure kernel, the vlan tagging is removed in Linux kernel.
Comment 1 Anitha 2015-09-18 02:35:34 EDT
could someone please respond to this vlan stripping in Rx Linux? Please let me know if specific information is required. we wanted to know the working version of vlan tagging in 3.x/4.x version of kernel.

Appreciate your inputs.
Comment 2 Anitha 2015-09-21 01:12:45 EDT
it seems Rx vlan tagging behavior in Linux is changed between 2.6.32-504.16.2(working) and 2.6.32-504.23.4(failed). The issue is still seen in latest 2.6.32-573.3.1.el6.i686. could someone please look into this issue in priority?

Thanks..
Comment 3 Prarit Bhargava 2015-09-22 08:16:46 EDT

*** This bug has been marked as a duplicate of bug 1264316 ***

Note You need to log in before you can comment on or make changes to this bug.