Red Hat Satellite engineering is moving the tracking of its product development work on Satellite to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "Satellite project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs will be migrated starting at the end of May. If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "Satellite project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/SAT-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.
Bug 1263610 - Unable to add BMC interface
Summary: Unable to add BMC interface
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Power & BMC
Version: 6.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: Unspecified
Assignee: Lukas Zapletal
QA Contact: Sachin Ghai
URL: http://projects.theforeman.org/issues...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-09-16 09:52 UTC by Lukas Zapletal
Modified: 2019-08-15 05:26 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-10-15 18:20:49 UTC
Target Upstream Version:
Embargoed:


Attachments (Terms of Use)
No power-cycle dropdown when BMC interface status is off (59.77 KB, image/png)
2015-10-07 08:33 UTC, Sachin Ghai
no flags Details
enabled BMC interface with power-cycle options (60.82 KB, image/png)
2015-10-07 09:16 UTC, Sachin Ghai
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1911 0 normal SHIPPED_LIVE Satellite 6.1.3 bug fix update 2015-10-15 22:19:19 UTC

Description Lukas Zapletal 2015-09-16 09:52:52 UTC
Create new host, add BMC interface, submit.

undefined method `has_feature?' for #<SmartProxy:0x0000000f780c30>

> NoMethodError
> undefined method `has_feature?' for #<SmartProxy:0x0000000e233ad0>
> app/models/nic/bmc.rb:45:in `block in bmc_proxy'
> app/models/nic/bmc.rb:45:in `each'
> app/models/nic/bmc.rb:45:in `find'
> app/models/nic/bmc.rb:45:in `bmc_proxy'
> app/models/nic/bmc.rb:54:in `validate_bmc_proxy'
> app/models/concerns/orchestration.rb:47:in `valid?'
> app/models/concerns/orchestration.rb:47:in `valid?'
> app/models/concerns/foreman/sti.rb:29:in `save_with_type'
> app/controllers/hosts_controller.rb:110:in `block in update'
> app/models/taxonomy.rb:58:in `block in no_taxonomy_scope'
> app/models/taxonomy.rb:65:in `block (2 levels) in as_taxonomy'
> app/models/concerns/foreman/thread_session.rb:148:in `as_location'
> app/models/taxonomy.rb:64:in `block in as_taxonomy'
> app/models/concerns/foreman/thread_session.rb:113:in `as_org'
> app/models/taxonomy.rb:63:in `as_taxonomy'
> app/models/taxonomy.rb:57:in `no_taxonomy_scope'
> app/controllers/hosts_controller.rb:102:in `update'
> app/models/concerns/foreman/thread_session.rb:33:in `clear_thread'
> lib/middleware/catch_json_parse_errors.rb:9:in `call'

Sat 6.1 GA

Comment 1 Lukas Zapletal 2015-09-16 10:09:36 UTC
Backporting this issue fixes it: fixes #10287 - provide helper methods for proxy features

Comment 2 Lukas Zapletal 2015-09-16 10:11:19 UTC
commit 8f657a8422a1ab85defaa9a999cc79c32ccfb1c6
Refs: 0.1-3735-g8f657a8
Author:     Stephen Benjamin <stbenjam>
AuthorDate: Tue Apr 28 12:43:31 2015 +0200
Commit:     Daniel Lobato <elobatocs>
CommitDate: Thu Apr 30 09:52:11 2015 +0200

    fixes #10287 - provide helper methods for proxy features
---
 app/helpers/smart_proxies_helper.rb          |  4 ++--
 app/models/concerns/host_common.rb           |  2 +-
 app/models/concerns/host_template_helpers.rb |  2 +-
 app/models/nic/bmc.rb                        |  2 +-
 app/models/smart_proxy.rb                    | 13 ++++++++-----
 app/models/subnet.rb                         |  2 +-
 lib/foreman/renderer.rb                      |  2 +-
 test/unit/smart_proxy_test.rb                | 16 +++++++++++-----
 8 files changed, 26 insertions(+), 17 deletions(-)

Comment 6 Sachin Ghai 2015-10-07 08:33:03 UTC
Verified this bz with latest sat 6.1.3 release.

I enabled the BMC feature on proxy and tried to create a new host with BMC interface (I tried both managed and un-managed). Interface was added successfully. I can see BMC tab on host details page. However I've two observations:

1.) BMC interface is in off state.
2.) no power-cycle dropdown available on right side of screen. Is it because interface status is off ?


Can anyone please confirm if its expected behaviour or its a regression ?

Thanks

Comment 7 Sachin Ghai 2015-10-07 08:33:53 UTC
Created attachment 1080548 [details]
No power-cycle dropdown when BMC interface status is off

Comment 8 Sachin Ghai 2015-10-07 09:15:43 UTC
Please ignore the previous comments 6 and 7. I was trying that with libvirt. and got to know  from dev "a host cant have both a compute resource and a bmc interface (bmc exists only for bare metal)"

So this time I tested with discovered_host, which can be treated as baremetal. Now I can see BMC interface on created host with power-cycle options.

Please see the attached screenshot for verification. thanks

Comment 9 Sachin Ghai 2015-10-07 09:16:31 UTC
Created attachment 1080559 [details]
enabled BMC interface with power-cycle options

Comment 10 Sachin Ghai 2015-10-07 09:18:34 UTC
Moving this to verified based on comment 8 and 9.

Comment 12 errata-xmlrpc 2015-10-15 18:20:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:1911


Note You need to log in before you can comment on or make changes to this bug.