Bug 1263647 - Deployment frozen on selecting subscriptions with no error message
Deployment frozen on selecting subscriptions with no error message
Status: CLOSED EOL
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: Installation - RHCI (Show other bugs)
1.0
Unspecified Unspecified
high Severity unspecified
: ga
: 1.0
Assigned To: Erik Nelson
Dave Johnson
Dan Macpherson
: Triaged
Depends On:
Blocks: qci-sprint-17
  Show dependency treegraph
 
Reported: 2015-09-16 06:55 EDT by Antonin Pagac
Modified: 2016-06-08 14:30 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-08 14:30:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of the problem (71.15 KB, image/png)
2015-09-16 06:55 EDT, Antonin Pagac
no flags Details

  None (edit)
Description Antonin Pagac 2015-09-16 06:55:55 EDT
Created attachment 1073967 [details]
Screenshot of the problem

Description of problem:
When creating a deployment, it freezes after the Subscription section (see screenshot) with message "Loading Data from Tasks..." and traceback in production.log.

Version-Release number of selected component (if applicable):
RHCI-6.0-RHEL-7-20150915.t.0-RHCI-x86_64-dvd1.iso

How reproducible:
Always

Steps to Reproduce:
1. Create a new RHCI deployment
2. It freezes at step 5A
3.

Actual results:
Deployment frozen, unable co continue

Expected results:
Deployment successful

Additional info:
Comment 2 Jason Montleon 2015-09-23 12:00:42 EDT
I see the same with recent composes as well.
Comment 3 Tzach Shefi 2015-09-24 08:28:27 EDT
I just this too with  
Media ID 1442368920.703351 - RHCI-6.0-RHEL-7-20150915.t.0-RHCI-x86_64-dvd1.iso

Ran a few times get stuck same error, deleted deployment tried again same error. 
Uploaded production log as well.
Comment 5 John Matthews 2015-10-13 14:10:57 EDT
I've seen this in the past when my UI code was out of date.

Joseph, is there anything we can do to avoid this in future....maybe catch an error and display instead of leaving the "Loading...." text up?
Comment 6 jmagen@redhat.com 2015-11-17 07:15:59 EST
Yes, error handling needs to be improved. 

After this commit, the message "Loading Data from Tasks..." was removed so it shoudn't appear, but not just if the error is captured.
https://github.com/fusor/fusor/commit/ee19bd9d739d121fd182b0d012c8b15d602b29a5

I changed title of bug to be "Deployment frozen on selecting subscriptions with no error message"
Comment 7 John Matthews 2016-06-08 09:07:12 EDT
I hit below issue recently with a development environment, I was running latest built assets (ran ember build prior to vagrant up so this is different than comment #5)



I think this might be an issue with:
 - Fresh Sat instance (first time creating a deployment)
 - Browser has state from a prior deployment (usage of 'rhci-test' for portal account)


Issue is I am stuck at Step 4A . 
I have not yet entered the credentials for the portal account, the screen hasn't fully rendered yet...
an exception was thrown from "verify_logged_in", further it was looking at "rhci-test/owners"...but I didn't enter anything yet for the account, so makes me think there is some cached data from browser which is being used.

Note:  I can get past this issue if I manually refresh the screen, it brings me back to Step 3, I can then advance to step 4 with no issues.


2016-06-07T17:28:59 [katello/cp_rest] [D] {"parentOwner":null,"id":"ff808081552c771101552c7ea7cb0001","key":"Default_Organization","displayN
ame":"Default Organization","contentPrefix":"/Default_Organization/$env","defaultServiceLevel":null,"upstreamConsumer":null,"logLevel":null,
"href":"/owners/Default_Organization","created":"2016-06-07T20:12:25.931+0000","updated":"2016-06-07T20:12:25.931+0000"}
2016-06-07T17:29:00 [app] [E] *** ERROR: Customer portal credentials are required.  Please provide them using login. (401) ***
2016-06-07T17:29:00 [app] [E] REQUEST URL: /customer_portal/users/rhci-test/owners
2016-06-07T17:29:00 [app] [E] Katello::HttpErrors::Unauthorized: Customer portal credentials are required.  Please provide them using login.
 | /git/RHCI/SAT62/fusor/server/app/controllers/fusor/api/customer_portal/customer_portal_proxies_controller.rb:76:in `verify_logged_in'




Full development.log is available in the gist below

# gist development.log 
https://gist.github.com/4165d5b456217243f82f2a0939f52bf9
Comment 8 John Matthews 2016-06-08 14:30:08 EDT
Turns out the issue we hit in comment #7 was not related to original intent of this BZ.


We are closing this BZ as the code has changed enough from when this was originally written that this BZ is no longer appropriate.

Note You need to log in before you can comment on or make changes to this bug.