Bug 1263655 - PSM support missing
PSM support missing
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openmpi (Show other bugs)
24
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michal Schmidt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-16 07:14 EDT by Dave Love
Modified: 2016-10-31 03:36 EDT (History)
3 users (show)

See Also:
Fixed In Version: openmpi-1.10.4-3 openmpi-1.10.4-4.fc25
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-31 03:36:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Love 2015-09-16 07:14:06 EDT
Description of problem:

I notice there's no support for the PSM MTL needed for "the other"
Infiniband hardware from Intel (whatever it's called this year).

It is provided in RHEL as the openmpi-psm package, depending on
infinipath-psm.  infinipath-psm isn't in Fedora, but the el6 source
package builds directly on f22.

Infinipath packaging would also be relevant to libfabric, but I
don't know if building openmpi-1.10 against libfabric would be equivalent
to the PSM MTL.
Comment 1 Orion Poplawski 2015-09-18 23:47:24 EDT
Personally, I don't have any time/interest to work on this.  But if psm/psm2/whatever were packaged for Fedora, it would be trivial to enable openmpi support.
Comment 2 Jan Kurik 2016-02-24 08:45:31 EST
This bug appears to have been reported against 'rawhide' during the Fedora 24 development cycle.
Changing version to '24'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora24#Rawhide_Rebase
Comment 3 Dave Love 2016-05-05 11:35:00 EDT
FWIW, I noticed infinipath-psm is recently packaged.
Comment 4 Michal Schmidt 2016-06-15 09:13:33 EDT
libpsm2 is available in Rawhide (but not in F24). To build openmpi with PSM2 support it should be sufficient to add libpsm2-devel to BuildRequires.

However, openmpi does not build in Rawhide, due to glibc finally poisoning the __malloc_initialize_hook symbol:
https://sourceware.org/bugzilla/show_bug.cgi?id=19564
https://sourceware.org/git/gitweb.cgi?p=glibc.git;a=commitdiff;h=2ba3cfa1607c36613f3b30fb1ae4ec530245ce64

In file included from btl_openib_component.c:58:0:
../../../../opal/mca/memory/linux/malloc.h:233:29: error: attempt to use poisoned "__malloc_initialize_hook"
 OPAL_DECLSPEC extern void (*__malloc_initialize_hook) __MALLOC_PMT ((void));
                             ^
Comment 5 Michal Schmidt 2016-06-15 10:25:10 EDT
v1.10.3 (upstream release likely to happen today) will build against the new glibc, because ./configure added a check for "__malloc_initialize_hook", so it will disable MCA component memory:linux.

https://github.com/open-mpi/ompi-release/commit/c2798a8bd6dddf68b69608ee04500261a0eda842
Comment 6 Orion Poplawski 2016-10-20 18:28:01 EDT
Built for rawhide.  Hope to move to older releases in a bit.
Comment 7 Fedora Update System 2016-10-26 00:24:04 EDT
openmpi-1.10.4-4.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-9b130deecb
Comment 8 Fedora Update System 2016-10-31 03:36:29 EDT
openmpi-1.10.4-4.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.