Bug 1263657 - (CVE-2015-5714, CVE-2015-5715, CVE-2015-7989) CVE-2015-5714 CVE-2015-5715 CVE-2015-7989 wordpress: XSS and permission issue fixed in wordpress 4.3.1
CVE-2015-5714 CVE-2015-5715 CVE-2015-7989 wordpress: XSS and permission issue...
Status: CLOSED CURRENTRELEASE
Product: Security Response
Classification: Other
Component: vulnerability (Show other bugs)
unspecified
All Linux
medium Severity medium
: ---
: ---
Assigned To: Red Hat Product Security
impact=moderate,public=20150915,repor...
: Security
Depends On: 1263658 1263659
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-16 07:15 EDT by Adam Mariš
Modified: 2016-01-08 06:38 EST (History)
3 users (show)

See Also:
Fixed In Version: wordpress 4.3.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-29 10:33:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Mariš 2015-09-16 07:15:32 EDT
Multiple vulnerabilities were found in versions prior to 4.3.1.

1. Cross-site scripting vulnerability when processing shortcode tags (CVE-2015-5714)
2. Cross-site scripting vulnerability in the user list table
3. Vulnerability allowing users without proper permissions to publish private posts and make them sticky (CVE-2015-5715)

Upstream patches:

1. https://github.com/WordPress/WordPress/commit/f72b21af23da6b6d54208e5c1d65ececdaa109c8
2. https://github.com/WordPress/WordPress/commit/f91a5fd10ea7245e5b41e288624819a37adf290a
3. https://github.com/WordPress/WordPress/commit/9c57f3a4291f2311ae05f22c10eedeb0f69337ab

External reference:

https://wordpress.org/news/2015/09/wordpress-4-3-1/
Comment 1 Adam Mariš 2015-09-16 07:16:26 EDT
Created wordpress tracking bugs for this issue:

Affects: fedora-all [bug 1263658]
Affects: epel-all [bug 1263659]
Comment 2 Fedora Update System 2015-09-25 03:57:29 EDT
wordpress-4.3.1-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 3 Fedora Update System 2015-09-25 06:53:31 EDT
wordpress-4.3.1-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.
Comment 4 Fedora Update System 2015-09-25 08:19:01 EDT
wordpress-4.3.1-1.fc21 has been pushed to the Fedora 21 stable repository. If problems still persist, please make note of it in this bug report.
Comment 5 Fedora Update System 2015-10-05 15:22:22 EDT
wordpress-4.3.1-1.el5 has been pushed to the Fedora EPEL 5 stable repository. If problems still persist, please make note of it in this bug report.
Comment 6 Fedora Update System 2015-10-06 23:06:34 EDT
wordpress-4.3.1-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2015-10-07 00:06:57 EDT
wordpress-4.3.1-1.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.
Comment 8 Martin Prpič 2015-10-29 10:33:00 EDT
(In reply to Adam Mariš from comment #0)
> Multiple vulnerabilities were found in versions prior to 4.3.1.
> ...
> 2. Cross-site scripting vulnerability in the user list table

This was additionally assigned CVE-2015-7989:

http://seclists.org/oss-sec/2015/q4/178

Note You need to log in before you can comment on or make changes to this bug.