Bug 1263696 - Memcached not built with SASL support
Memcached not built with SASL support
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: memcached (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: pre-dev-freeze
: 7.3
Assigned To: Miroslav Lichvar
Leos Pol
:
Depends On:
Blocks: 1252087 1304473 1304493
  Show dependency treegraph
 
Reported: 2015-09-16 08:36 EDT by Yanis Guenane
Modified: 2016-11-03 20:35 EDT (History)
7 users (show)

See Also:
Fixed In Version: memcached-1.4.15-10.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1304473 (view as bug list)
Environment:
Last Closed: 2016-11-03 20:35:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yanis Guenane 2015-09-16 08:36:20 EDT
Description of problem:

Currently memcached in base is not build with SASL support preventing to secure the memcached instance.


Version-Release number of selected component (if applicable):

memcached-1.4.15-9.el7.x86_64


How reproducible:

always


Steps to Reproduce:
1. Spawn a C7 node
2. yum install memcached
3. vi /etc/sysconfig/memcached (add '-S' in OPTIONS="")
4. start memcached 

Actual results:

Service fails to start with error message :

memcached[18804]: This server is not built with SASL support.


Expected results:

Service should start manually

Additional info:
Comment 1 Lars Kellogg-Stedman 2015-09-16 09:18:40 EDT
Should this be against RHEL rather than RDO?  That's where the memcache package lives.
Comment 2 Hugh Brock 2016-02-03 12:11:57 EST
We'll need this package rebuilt for secure memcached support in RHELOSP 8.
Comment 13 errata-xmlrpc 2016-11-03 20:35:27 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2213.html

Note You need to log in before you can comment on or make changes to this bug.