Bug 126370 - running switchdesk with bad option creates bad .Xclient* files
Summary: running switchdesk with bad option creates bad .Xclient* files
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: switchdesk   
(Show other bugs)
Version: 2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-06-20 13:47 UTC by Andre Robatino
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-24 14:41:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Andre Robatino 2004-06-20 13:47:40 UTC
Description of problem:
  Running switchdesk with a bad command-line option, for example

switchdesk -help

creates a .Xclients file only in the user's home directory.  Since
this file attempts to execute either ~/.Xclients/$HOSTNAME$DISPLAY or
~/.Xclients-default, neither of which is created, one is unable to log
into the default GNOME session.  One fix might be to just modify
.Xclients so it checks whether .Xclients-default exists before trying
to execute it.

Version-Release number of selected component (if applicable):
switchdesk-4.0.3-1

How reproducible:
always

Steps to Reproduce:
1. Run switchdesk with a bad option (for example "switchdesk -help"),
making sure that no ~/.Xclients* files already exist.
2. Log out.
3. Try to log in using the default GNOME session.
  
Actual results:
  Error message ("Your session only lasted less than 10 seconds. ...")
and you get the option to see details, which shows ~/.Xclients exists
but ~/.Xclients-default doesn't.  Upon closing, one is back at the
login screen.

Expected results:
  Should be able to log into the default session normally.

Comment 1 Andre Robatino 2004-06-20 14:41:08 UTC
  Sorry, this bug report is a dupe.  For some reason, bugzilla showed
no switchdesk bugs last time I queried, but this time it shows several
bugs including this one already reported.

Comment 2 Ngo Than 2004-06-24 14:41:21 UTC
it's fixed in switchdesk-4.0.4-1, which should show up in rawhide.
Thanks for your report


Note You need to log in before you can comment on or make changes to this bug.