Bug 1263718 - undocumented new options for hwlatdetect and cyclictest
undocumented new options for hwlatdetect and cyclictest
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rt-tests (Show other bugs)
7.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 7.3
Assigned To: John Kacur
Jiri Kastner
:
Depends On:
Blocks: 1263719 1313485 1274397 RT7.3-Prio
  Show dependency treegraph
 
Reported: 2015-09-16 09:46 EDT by Jiri Kastner
Modified: 2016-11-04 01:13 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1263719 (view as bug list)
Environment:
Last Closed: 2016-11-04 01:13:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Update the cyclictest man page (17.28 KB, application/mbox)
2016-04-25 10:22 EDT, John Kacur
no flags Details
rt-tests-Update-the-cyclictest-man-page.patch (17.82 KB, patch)
2016-04-25 12:47 EDT, John Kacur
no flags Details | Diff
Add missing option to hwlatdetect man-page (2.49 KB, patch)
2016-05-20 08:19 EDT, John Kacur
no flags Details | Diff

  None (edit)
Description Jiri Kastner 2015-09-16 09:46:30 EDT
Description of problem:
0.93 version added new options for cyclictest and hwlatdetect, which are not documented in man page.

Version-Release number of selected component (if applicable):
0.93

How reproducible:
always on 0.93

Steps to Reproduce:
1. install rt-tests-0.93
2. compare output of 'cyclictest --help' and 'man cyclictest'
3. compare output of 'hwlatdetect --help' and 'man hwlatdetect'

Actual results:
missing '--watch' option for hwlatdetect and '--secaligned' for cyclictest

Expected results:
all options documented

Additional info:
Comment 1 Jiri Kastner 2015-09-16 09:47:12 EDT
############# reproducer ##############
[root@dell-per815-02 ~]# zcat /usr/share/man/man8/cyclictest.8.gz | man2html | grep "\-\-numa"
<DT><B>\-U, --numa</B>
[root@dell-per815-02 ~]# cyclictest --help | grep "\-\-numa"
-U       --numa            Standard NUMA testing (similar to SMP option)
[root@dell-per815-02 ~]# zcat /usr/share/man/man8/cyclictest.8.gz | man2html | grep "\-\-secali"
[root@dell-per815-02 ~]# cyclictest --help | grep "\-\-secali"
         --secaligned [USEC] align thread wakeups to the next full second,
[root@dell-per815-02 ~]# zcat /usr/share/man/man8/hwlatdetect.8.gz| man2html | grep "\-\-watch"
[root@dell-per815-02 ~]# hwlatdetect --help | grep "\-\-watch"
  --watch               print sample data to stdout as it arrives
[root@dell-per815-02 ~]#
Comment 4 John Kacur 2016-04-25 10:22 EDT
Created attachment 1150522 [details]
Update the cyclictest man page

I just sent this patch upstream
Comment 5 John Kacur 2016-04-25 12:47 EDT
Created attachment 1150556 [details]
rt-tests-Update-the-cyclictest-man-page.patch

Here's an updated version of the patch with some spell fixes and and ack from Clark
Comment 6 John Kacur 2016-05-20 08:19 EDT
Created attachment 1159892 [details]
Add missing option to hwlatdetect man-page
Comment 7 John Kacur 2016-05-20 08:48:28 EDT
Fixed in
rt-tests-1.0-1.el7rt-tests-1.0-1.el7
and up
Comment 11 errata-xmlrpc 2016-11-04 01:13:59 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2391.html

Note You need to log in before you can comment on or make changes to this bug.