Bug 1263753 - Process Instance Details screen: Activity not found
Process Instance Details screen: Activity not found
Status: VERIFIED
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.2.0
Unspecified Unspecified
high Severity high
: ER3
: 6.3.0
Assigned To: Cristiano Nicolai
Jan Hrcek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-16 11:16 EDT by manstis
Modified: 2016-04-14 04:42 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen shot to make hunting easier... (99.22 KB, image/png)
2015-09-16 11:16 EDT, manstis
no flags Details
Screenshot showing issue still present (just error message changed) (51.45 KB, image/png)
2016-03-18 06:04 EDT, Jan Hrcek
no flags Details

  None (edit)
Description manstis 2015-09-16 11:16:16 EDT
Created attachment 1074078 [details]
screen shot to make hunting easier...

Description of problem:

kie-drools-wb-6.3.0.Final.

I configured a "Managed Repository", created a DRL file and "Promoted" it to another branch. This worked fine. I was looking through the tabs on the "Asset Management Tasks" (Tasks List Screen) and clicked on a task (to promote the assets). On the "Select Assets To Promote" (RHS) of the screen I then clicked on the "Process Context" tab and finally the "Process Instance details" button. This is when I received the notification that the "Process instance" activity could not be found.

Version-Release number of selected component (if applicable):

kie-drools-wb-6.3.0.Final

How reproducible:

Always

Steps to Reproduce:
See above

Actual results:

A notification that an Activity could not be found.

Expected results:

IDK to be honest; but I suspect not the error message.

Additional info:
Comment 2 Mauricio Salatino 2015-09-28 04:28:53 EDT
Hmm.. yes.. that's an expected issue.. that I'm not 100% sure how to solve. We would like to avoid having hacks for the different distributions in the different screens. 
In theory we shouldn't have the New Task button either in the KIE-DROOLS-WB, because the screen is supposed to be only for the task created by the Asset MGMT features only. Due the lack of time and feedback about the Asset Management feature in general we haven't made any progress.. We should include to this BZ removing the New Task button as well
Comment 4 Jan Hrcek 2016-03-18 06:03:32 EDT
The issue is still present. I tried the steps described by Michael in BRMS (NOT BPM Suite!) 6.3.0 ER1 and got similar result (see screenshot).

From the screenshot it's clear that the commit is present in the product (error showing the "DataSet Process Instances With Variables" which was the change in Christiano's commit)

Please review.
Comment 5 Jan Hrcek 2016-03-18 06:04 EDT
Created attachment 1137735 [details]
Screenshot showing issue still present (just error message changed)
Comment 6 Cristiano Nicolai 2016-04-05 19:16:14 EDT
Revisited implementation and pushed a new fix, please verify.

https://github.com/droolsjbpm/jbpm-console-ng/commit/2cc33564cfe4bf5f9496d4516625625ac03e08f8
Comment 7 Cristiano Nicolai 2016-04-05 19:16:56 EDT
Also as part of the update, the New Task button has been removed from the task list screen.
Comment 8 Jan Hrcek 2016-04-14 04:42:06 EDT
Now it works as expected: "Process instance details" button is disabled & "New Task" button is not present at all. Verified with BRMS 6.3.0 ER3.

Note You need to log in before you can comment on or make changes to this bug.