Bug 1263759 - Kerberos User moves the mouse while screen saver is locked. (Ignore set. Enforce smart card: OFF) - prompts and accepts kerber user password to unlock screen
Kerberos User moves the mouse while screen saver is locked. (Ignore set. Enfo...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-shell (Show other bugs)
7.2
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Ray Strode [halfline]
Desktop QE
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-16 11:34 EDT by Roshni
Modified: 2015-11-19 02:21 EST (History)
6 users (show)

See Also:
Fixed In Version: gnome-shell-3.14.4-33.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 02:21:18 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:2216 normal SHIPPED_LIVE gnome compositor stack bug fix and enhancement update 2015-11-19 03:26:34 EST

  None (edit)
Description Roshni 2015-09-16 11:34:46 EDT
Description of problem:
Kerberos User moves the mouse while screen saver is locked. (Ignore set. Enforce smart card: OFF) - prompts and accepts kerber user password to unlock screen

Version-Release number of selected component (if applicable):
gnome-shell-3.14.4-27.el7

How reproducible:
always

Steps to Reproduce:
1. Enroll a smartcard with a kerberos user
2. Using authconfig enable smartcard login and Disable "Require Smartcard for login"
3. Login using smartcard pin
4. Lock the screen


Actual results:
When the smartcard is not inserted, the kerberos user password is prompted (no message to insert smartcard) and unlocks the screen when the password is provided.

Expected results:
A message is displayed to the user asking them to insert the smart card they used to login previously (Kerberos password should not be prompted)

Additional info:
Comment 3 Ray Strode [halfline] 2015-09-28 20:07:42 EDT
this should be fixed in gnome-shell-3.14.4-33.el7
Comment 5 Roshni 2015-10-01 10:02:25 EDT
[root@dhcp129-12 ~]# rpm -qi gnome-shell
Name        : gnome-shell
Version     : 3.14.4
Release     : 33.el7
Architecture: x86_64
Install Date: Thu 01 Oct 2015 09:49:38 AM EDT
Group       : User Interface/Desktops
Size        : 9686336
License     : GPLv2+
Signature   : (none)
Source RPM  : gnome-shell-3.14.4-33.el7.src.rpm
Build Date  : Mon 28 Sep 2015 10:20:52 PM EDT
Build Host  : x86-034.build.eng.bos.redhat.com
Relocations : (not relocatable)
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
Vendor      : Red Hat, Inc.
URL         : http://live.gnome.org/GnomeShell
Summary     : Window management and application launching for GNOME

Vertification steps:

1. Enroll a smartcard with a kerberos user
2. Using authconfig enable smartcard login and Disable "Require Smartcard for login"
3. Login using smartcard pin
4. Lock the screen
5. When smartcard is not inserted - A message is displayed to the user asking them to insert the smart card they used to login previously (Kerberos password is not prompted)
Comment 6 errata-xmlrpc 2015-11-19 02:21:18 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2216.html

Note You need to log in before you can comment on or make changes to this bug.