Bug 1263782 - noVNC console on Openstack Dashboard is rendering garbled UI on RHEL7
noVNC console on Openstack Dashboard is rendering garbled UI on RHEL7
Status: CLOSED UPSTREAM
Product: Red Hat OpenStack
Classification: Red Hat
Component: novnc (Show other bugs)
7.0 (Kilo)
x86_64 Unspecified
unspecified Severity high
: ---
: 7.0 (Kilo)
Assigned To: Solly Ross
Shai Revivo
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-16 12:55 EDT by Abhishek
Modified: 2016-04-25 16:45 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-25 16:45:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Garbled UI (482.33 KB, image/png)
2015-09-16 12:55 EDT, Abhishek
no flags Details

  None (edit)
Description Abhishek 2015-09-16 12:55:06 EDT
Created attachment 1074135 [details]
Garbled UI

Description of problem:

I am running openstack nova-compute on RHEL7 and RHEL7.1. Openstack dashboard's noVNC console is rendering garbled UI for any instance having a UI console. This is working just fine on RHEL65


How reproducible:
100% of the times


Steps to Reproduce:
1.Provision an instance with openstack. The instance should have a desktop (e.g. Windows)
2. Open VNC Console on Horizon dashboard
3. UI is rendered with BLACK Strips and is not readable.

Actual results:
UI rendered is totally garbled and is unreadable.

Expected results:
UI should be clear.

Additional info:
This does work perfectly on RHEL6.5
Comment 2 Gerd Hoffmann 2015-09-17 03:33:21 EDT
Possibly bug 1247479 duplicate.

Can you double-check whevener this really is vnc?
There is a web client for spice too.
Comment 3 Jiri Denemark 2015-09-17 03:57:57 EDT
Anyway, I can't imagine how this could be a libvirt issue. Moving to qemu-kvm-rhev for now.
Comment 4 Ademar Reis 2015-09-17 09:56:54 EDT
Abhishek, thanks for taking the time to enter a bug report with us. We use reports like yours to keep improving the quality of our products and releases. That said, we're not able to guarantee the timeliness or suitability of a resolution for issues entered here because this is not a mechanism for requesting support.

If this issue is critical or in any way time sensitive, please raise a ticket through your regular Red Hat support channels to make certain it receives the proper attention and prioritization that will result in a timely resolution.

For information on how to contact the Red Hat production support team, please visit: https://www.redhat.com/support/process/production/#howto
Comment 5 Abhishek 2015-09-17 14:53:55 EDT
@Gerd Hoffman,  thanks for your quick response and looking into this.

The client is noVNC. It's an openstack setup and nova-novncproxy service uses noVNC as the default client. And the problem just occurs on any guest running a desktop on it (not necessarily windows)

I tried experimenting with decreasing the VRAM to 9126 which was earlier the default for RHEL65 (actually now it has to be in powers of 2 so I made it 8192) thinking that 16MB would be huge data to be rendered on the browser canvas, but that didn't help. 

I have got both RHEL65 and RHEL71 and it does work for RHEL65.

@Ademar Reis, Thanks for pointing the direction. It's actually a time sensitive and critical stuff. Our support matrix has got RHEL71 and we desperately need atleast a workaround to make the VNC console usable.
I will post the bug to your Red Hat production support team as well.
Comment 6 Gerd Hoffmann 2015-09-18 10:37:17 EDT
Ok, novnc is buggy.  Bisected to "6940936 WIP: Switch to Pako for zlib".

Whom should this be reassigned to?
Comment 7 Ademar Reis 2015-09-18 11:01:59 EDT
I'm moving this BZ to the novnc component, under Red Hat Open Stack product.

Abhishek: I hope the support team is able to assist you (please refer them to this BZ if you haven't done so yet). As pointed out by Gerd above (comment #6), novnc appears to be broken and the commit that introduced the issue is "6940936 WIP: Switch to Pako for zlib".

But keep in mind that noVNC is not a supported package in RHEL7 (I don't know if your subscription covers only RHEL or Red Hat OpenStack). For RHEL7, noVNC is part of EPEL, which is community supported.
Comment 9 Solly Ross 2015-09-22 16:52:28 EDT
This commit should fix the issue -- please let me know if it does (sorry for the delayed response): https://github.com/kanaka/noVNC/pull/532
Comment 10 Abhishek 2015-09-29 05:33:36 EDT
Works like a charm :)
Thanks a ton @Sally Ross.
Comment 12 Lon Hohberger 2016-04-25 16:45:36 EDT
It appears this bug was introduced (and later fixed) in upstream code after v0.5.1, the version included in Red Hat OpenStack Platform:

https://github.com/kanaka/noVNC/compare/v0.5.1...master

Note You need to log in before you can comment on or make changes to this bug.