Bug 1263788 - Test case failure: Outputs - DP on ATI Pitcairn PRO [Radeon HD 7850] [1002:6819]
Test case failure: Outputs - DP on ATI Pitcairn PRO [Radeon HD 7850] [1002:6819]
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: xorg-x11-drv-ati (Show other bugs)
7.2
x86_64 Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Jérôme Glisse
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-16 13:11 EDT by Vasiliy Sharapov
Modified: 2015-09-23 10:34 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-23 10:34:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vasiliy Sharapov 2015-09-16 13:11:51 EDT
Filed from caserun (https://tcms.engineering.redhat.com/run/260129/#caserun_10820272)

Version-Release number of selected component (if applicable):
RHEL-7.2-20150820.0
xorg-x11-server-Xorg-1.17.2-7.el7.x86_64
xorg-x11-drv-ati-7.5.0-3.el7.x86_64
kernel-3.10.0-306.0.1.el7.x86_64
linux-firmware-20150727-41.git75cc3ef.el7.noarch
mesa-dri-drivers-10.6.0-1.20150616.el7.x86_64

Steps to Reproduce: 
obtain a box with DP output  and as much screens as can be attached


 1. connect screens through DP port
 2. perform suspend/resume cycle two times



Actual results: 
If machine booted without DP, hotplugging will cause it to reboot immediately.
Otherwise (if booted with DP plugged in) DP works, but repeated hotpluging with 3+ monitors will cause it to stop working (xrandr will show DP monitor as working, but the monitor will go to sleep from lack of signal).


Expected results:
Screens should be correctly set, their native resolution should be set and
suspend/resume cycles should work as well


Additional info:
DP also suffers from mild temporary corruption on wake from standby - same as every digital output on this video card, this is a separate bug: https://bugzilla.redhat.com/show_bug.cgi?id=1263784
Comment 1 Jérôme Glisse 2015-09-23 10:34:19 EDT
So talked with Vasiliy and we believe this was some electrical grounding issue on his test setup. We could not reproduce on mine.

Note You need to log in before you can comment on or make changes to this bug.