Bug 1263797 - Cluster CPU Type in RHEV set to different value than specified in deployment configuration during wizard
Cluster CPU Type in RHEV set to different value than specified in deployment ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: Installation - RHEV (Show other bugs)
1.0
Unspecified Unspecified
high Severity unspecified
: TP2
: 1.0
Assigned To: Dylan Murray
Tasos Papaioannou
Dan Macpherson
: Triaged
Depends On: rhci-sprint-12
Blocks: rhci-sprint-10
  Show dependency treegraph
 
Reported: 2015-09-16 13:52 EDT by Matt Reid
Modified: 2016-10-03 15:21 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-03 15:21:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Reid 2015-09-16 13:52:37 EDT
Description of problem:
During our deployment configuration, we set the CPU Type to Intel Nehalem, which is what our blades have for a CPU. Once everything had been deployed, the Cluster CPU Type that we can see in RHEV is set to Intel Westmere Family, which is a generation older than what we specified. 

Is that where we should see Nehalem set, or am I looking in the wrong spot? I don't see any other mention of CPU types in RHEV. I would expect the Cluster CPU Type to be Nehalem, not Westmere.

Version-Release number of selected component (if applicable):
Tech Preview


Additional info:
Comment 1 Stephen Herr 2015-10-28 17:36:40 EDT
Note to self:
The problem appears to be that the cpu_type option does nothing unless you are created the cluster, aka have changed the name to something other than "Default".
https://github.com/fusor/puppet-ovirt/blob/master/templates/dc_config.erb#L84=L94

We need to either update the puppet module to change the cpu_type on the cluster if it already exists (preferable), or have the UI force the user to change the cluster name if they set cpu_type if we can't do that.
Comment 2 Stephen Herr 2015-10-29 09:20:54 EDT
This should be fixed by https://github.com/fusor/puppet-ovirt/pull/3
Comment 3 John Matthews 2015-11-02 11:52:53 EST
Included in: ruby193-rubygem-fusor_server-0.0.1-70.el7
Comment 4 Antonin Pagac 2016-01-11 08:48:23 EST
I tried this by leaving DataCenter and Cluster names 'Default' and setting the processor type to Nehalem family in the RHCI UI, completely disregarding the processor family my host in fact has. The installed RHEV now shows cluster CPU type 'Intel SandyBridge family', which is not what I configured in the RHCI UI. I can see the Nehalem type configured on the Installation Review page. 
I then checked actual processor type on my hosts, and to the best of my and wiki knowledge it belongs to the Westmere family.

To summarize:
1. The actual cluster CPU type in RHEVM (SandyBridge) is not what I configured in RHCI UI (Nehalem)
2. The actual cluster CPU type in RHEVM (SandyBridge) is not the type of processor on the host machine (Westmere)

Version-Release number of selected component (if applicable):
ruby193-rubygem-fusor_server-0.0.1-85.el7.noarch
RHCI-6.0-RHEL-7-20160107.t.1-RHCI-x86_64-dvd1.iso
Comment 6 Dylan Murray 2016-01-21 08:53:52 EST
Noticed an issue where the CPU type may still not be set if there is no assigned parameter on the cluster. Investigating this behavior and will update the bug accordingly.
Comment 8 John Matthews 2016-01-22 15:21:11 EST
Compose of 1/22/16
Comment 9 Tasos Papaioannou 2016-01-28 09:53:15 EST
Verified on RHCI-6.0-RHEL-7-20160125.t.0.

Note You need to log in before you can comment on or make changes to this bug.