Bug 1263804 - Notifications shown for Lifecycle environments in 1C can be easily tricked
Notifications shown for Lifecycle environments in 1C can be easily tricked
Status: CLOSED CURRENTRELEASE
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: WebUI (Show other bugs)
1.0
Unspecified Unspecified
high Severity unspecified
: TP2
: 1.0
Assigned To: jmagen@redhat.com
Dave Johnson
: Triaged
Depends On:
Blocks: rhci-sprint-10
  Show dependency treegraph
 
Reported: 2015-09-16 14:18 EDT by Matt Reid
Modified: 2016-10-03 15:21 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-03 15:21:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Normal confirmation (117.69 KB, image/png)
2015-09-16 14:19 EDT, Matt Reid
no flags Details
After selecting Use Default Organization, when a confirmation message was active (23.63 KB, image/png)
2015-09-16 14:20 EDT, Matt Reid
no flags Details

  None (edit)
Description Matt Reid 2015-09-16 14:18:00 EDT
Description of problem:
When you create a lifecycle environment in 1C, there's a green status message that shows up, confirming that it has been created. The notification seems to be semi-permanent, and sticks around, without having a dismiss action. If you create a lifecycle environment, and then change your mind and check the box for Use Default Organization View, the message stays, but gets updated to remove the name of the environment that you just created, so that it says "(Checkmark) added successfully". It persists if you use the Back button and then move forward to return to this step. Seems like selecting a path dismisses the message, but if you check the box, there are no paths shown to click on.

Version-Release number of selected component (if applicable):
Tech Preview
Comment 1 Matt Reid 2015-09-16 14:19:13 EDT
Created attachment 1074159 [details]
Normal confirmation
Comment 2 Matt Reid 2015-09-16 14:20:59 EDT
Created attachment 1074160 [details]
After selecting Use Default Organization, when a confirmation message was active
Comment 3 jmagen@redhat.com 2015-10-15 03:12:23 EDT
Fixed https://github.com/fusor/fusor/pull/392
Comment 4 John Matthews 2015-11-02 11:56:49 EST
Included in: ruby193-rubygem-fusor_ui-0.0.1-84.el7
Comment 5 Antonin Pagac 2016-01-12 08:35:21 EST
Verified.

The UI changed a bit since this issue was reported. The "Use Default Organization view" checkbox was removed, default environment is now "Library". The green notification now disappears when other than added environment path is chosen, it does not update. It also does not persist when going Back and clicking Next again.

ruby193-rubygem-fusor_ui-0.0.1-98.el7.noarch
RHCI-6.0-RHEL-7-20160107.t.1-RHCI-x86_64-dvd1.iso

Note You need to log in before you can comment on or make changes to this bug.