Bug 1263822 - Non-existent jenkins-16-rhel7 image shows up via Customer Portal search
Non-existent jenkins-16-rhel7 image shows up via Customer Portal search
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Release (Show other bugs)
3.0.0
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Stanislav Graf
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-16 15:36 EDT by Alex Dellapenta
Modified: 2015-09-18 07:31 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-18 07:31:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Dellapenta 2015-09-16 15:36:10 EDT
Description of problem:

The Jenkins image was initially released as jenkins-16-rhel7, but was quickly renamed to jenkins-1-rhel7 (see [1]). The jenkins-1-rhel7 correctly shows up via Customer Portal container search (https://access.redhat.com/search/#/container-images) and via CLI "docker search", however jenkins-16-rhel7 still shows up in the Portal search, even though you cannot actually pull this image. It does not show up via "docker search".

[1] http://post-office.corp.redhat.com/archives/openshift-sme/2015-August/msg01532.html

Actual results:

Customer Portal container search, refining by "jenkins":

https://access.redhat.com/search/#/container-images?q=jenkins&p=1&sort=relevant&documentKind=ImageRepository

Now try pulling those images:

durant@santos:~$ sudo docker pull registry.access.redhat.com/openshift3/jenkins-16-rhel7
Trying to pull repository registry.access.redhat.com/openshift3/jenkins-16-rhel7 ... not found
Error: image openshift3/jenkins-16-rhel7:latest not found

durant@santos:~$ sudo docker pull registry.access.redhat.com/openshift3/jenkins-1-rhel7
Trying to pull repository registry.access.redhat.com/openshift3/jenkins-1-rhel7 ...
225d177d917d: Download complete 
275be1d3d070: Download complete 
Status: Image is up to date for registry.access.redhat.com/openshift3/jenkins-1-rhel7:latest

And here's a friendly-paste version when "docker search"ing, for comparison w/ the Portal search results:

http://pastebin.test.redhat.com/313301

Expected results:

The non-existent jenkins-16-rhel7 image should not show up when searching via Customer Portal (https://access.redhat.com/search/#/container-images).
Comment 2 Scott Dodson 2015-09-16 17:15:35 EDT
Tom, how do we get things like this removed automatically from portal?
Comment 3 Greg Sterling 2015-09-16 21:58:19 EDT
Stanslav,

Let me know if there is any help you need from Brendan or myself to help get this documented for RCM, to help resolve it or anything else.

Thanks!

Greg
Comment 4 Tom Butt 2015-09-17 08:28:53 EDT
Scott,
    Things show up in the portal that are provided in the feed that solr gets, currently the feed contains:
<record mimetype="text/html" url="https://access.redhat.com/docker-repo-item/redhat-openshift3-jenkins-16-rhel7">
<record mimetype="text/html" url="https://access.redhat.com/docker-repo-item/redhat-openshift3-jenkins-1-rhel7">

So, they both show up.  The fact that the docker search (CLI) doesn't show them means that it probably is removed from pulp, as Crane validates registry.access.redhat.com images it gets back from search (as it would get both back) against the pulp metadata (which probably only matches the new record, so the old one doesn't show up since Crane knows it can't deliver it from pulp.)

Does that help?  Basically the unified feed is still giving solr both records, so solr will be returning them, it's just not obvious in the CLI.
Comment 5 Lubos Kocman 2015-09-18 07:31:57 EDT
Hello,

I just unpublished the repository since it was empty.
Search now returns "No results found ".

Closing the bug.

Lubos

Note You need to log in before you can comment on or make changes to this bug.