Bug 1263823 - Control Action UI: Missing ability to set request message for "Invoke a Custom Action"
Control Action UI: Missing ability to set request message for "Invoke a Custo...
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.4.0
All All
high Severity urgent
: GA
: 5.4.3
Assigned To: Harpreet Kataria
Jeff Teehan
: ZStream
Depends On: 1263494
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-16 15:42 EDT by Chris Pelland
Modified: 2015-10-22 10:33 EDT (History)
13 users (show)

See Also:
Fixed In Version: 5.4.3.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1263494
Environment:
Last Closed: 2015-10-22 10:33:50 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 1980763 None None None Never

  None (edit)
Comment 2 CFME Bot 2015-09-17 11:01:46 EDT
New commit detected on cfme/5.4.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=de06d1b2404300ebf86b755c97bb8130e81685f0

commit de06d1b2404300ebf86b755c97bb8130e81685f0
Author:     Harpreet Kataria <hkataria@redhat.com>
AuthorDate: Wed Sep 16 16:15:18 2015 -0400
Commit:     Harpreet Kataria <hkataria@redhat.com>
CommitDate: Wed Sep 16 16:15:18 2015 -0400

    Fixed HAML indentation
    
    Incorrect HAML indentation was hiding some of the fields while trying to add/edit Action type "Invoke a Custom Automation".
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1263494
    https://bugzilla.redhat.com/show_bug.cgi?id=1263823

 .../views/layouts/_ae_resolve_options.html.haml    | 34 +++++++++++-----------
 1 file changed, 17 insertions(+), 17 deletions(-)
Comment 3 CFME Bot 2015-09-17 11:01:54 EDT
New commit detected on cfme/5.4.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=1dc5e41bbf8f1b6663873e75194fc51cbcb435d4

commit 1dc5e41bbf8f1b6663873e75194fc51cbcb435d4
Merge: 036ab23 de06d1b
Author:     Dan Clarizio <dclarizi@redhat.com>
AuthorDate: Thu Sep 17 10:40:07 2015 -0400
Commit:     Dan Clarizio <dclarizi@redhat.com>
CommitDate: Thu Sep 17 10:40:07 2015 -0400

    Merge branch '54z_bz_1263823' into '5.4.z'
    
    Fixed HAML indentation
    
    Incorrect HAML indentation was hiding some of the fields while trying to add/edit Action type "Invoke a Custom Automation".
    
    https://bugzilla.redhat.com/show_bug.cgi?id=1263494
    https://bugzilla.redhat.com/show_bug.cgi?id=1263823
    
    @dclarizi please review, clean patch applied
    
    Original PR: https://github.com/ManageIQ/manageiq/pull/4384
    
    See merge request !253

 .../views/layouts/_ae_resolve_options.html.haml    | 34 +++++++++++-----------
 1 file changed, 17 insertions(+), 17 deletions(-)
Comment 5 Jeff Teehan 2015-10-06 11:14:29 EDT
Using 5.4.3 (https://10.8.59.221/miq_policy/explorer) I was able to create a Custom Action as described above.  Checking my screen with that of the screenshots on github, they look correct.

Moving to Verified as the fix appears to have corrected the issue.
Comment 7 errata-xmlrpc 2015-10-22 10:33:50 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1916.html

Note You need to log in before you can comment on or make changes to this bug.