Bug 126387 - --exclude does not seem to work intuitively
--exclude does not seem to work intuitively
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Depends On:
  Show dependency treegraph
Reported: 2004-06-20 21:39 EDT by Bob Gustafson
Modified: 2014-01-21 17:49 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-10-11 15:10:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Bob Gustafson 2004-06-20 21:39:00 EDT
Description of problem:

  I have problems with update of evolution and php - they need
libraries which are not available (see below).

  Intuitively, if I exclude the update of these programs, problems
having to do with these programs will be skipped over.

  This does not happen. Only by constructing a series of yum updates
is this problem partially avoidable ( yum update a\*, yum update b\*,
... )

Version-Release number of selected component (if applicable):

[root@hoho2 etc]# rpm -q yum
[root@hoho2 etc]#

How reproducible:
  evolution is a new problem, php has been a problem for about a week.

Steps to Reproduce:
1. See below

Actual results:

[root@hoho2 etc]# yum --exclude=evolution --exclude=php update
Gathering header information file(s) from server(s)
Server: Fedora Core 2 - Development Tree
Finding updated packages
Downloading needed headers
Resolving dependencies
.Package evolution needs libsoup-2.0.so.0, this is not available.
Package evolution needs libgtkhtml-3.0.so.4, this is not available.
Package evolution needs libgal-2.0.so.6, this is not available.
Package evolution needs libgal-a11y-2.0.so.6, this is not available.
Package php needs libintl.so.3, this is not available.
[root@hoho2 etc]#

Expected results:
  yum update of everything else except the excluded programs

Additional info:
Comment 1 Seth Vidal 2004-06-23 01:43:37 EDT
b/c the other things libsoup, libgtkhtml, libgal, libgal-a11y and
libintl are being upgraded, it is php and evolution, that are still
installed, that are complaining about broken deps..

so when you exclude them from an upgrade you're causing the dep problem.
Comment 2 Bob Gustafson 2004-10-11 15:10:42 EDT
The solution to this problem is not to not exclude evolution from the
upgrade (upgrade of evolution was not available at the time), but to
just whack evolution, also php

rpm -e --nodeps evolution
rpm -e --nodeps php

Then, do the update

yum update

When this finishes, then reinstall evolution and php

yum install php
yum install evolution

If this last step does not succeed, then you are out of luck..

Has - worked for me

Note You need to log in before you can comment on or make changes to this bug.