Bug 126390 - Kernel 2.6.6-1.435 build fails with Power Management options
Kernel 2.6.6-1.435 build fails with Power Management options
Status: CLOSED DUPLICATE of bug 126342
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-20 22:47 EDT by Dave Wolinski
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:04:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dave Wolinski 2004-06-20 22:47:34 EDT
Description of problem:

I'm trying to build a custom kernel using kernel-sourcecode-2.6.6-1.435.

When I enable either the CONFIG_SOFTWARE_SUSPEND or CONFIG_PM_DISK
power management options, the kernel build fails with with the
following errors, respectively:

arch/i386/power/built-in.o(.text+0x1b4): In function
`pmdisk_arch_suspend':
: undefined reference to `swsusp_pg_dir'

arch/i386/power/built-in.o(.text+0x263): In function `do_magic':
: undefined reference to `swsusp_pg_dir'
make: *** [.tmp_vmlinux1] Error 1

Version-Release number of selected component (if applicable):
kernel-sourcecode-2.6.6-1.435


How reproducible: always


Steps to Reproduce:
1. install kernel-sourcecode-2.6.6-1.435 rpm
2. cd /usr/src/linux-2.6.6...
3. make mrproper
4. make bzImage
  

Actual results: build aborts on above error


Expected results: build should complete


Additional info:
Comment 1 Dave Wolinski 2004-06-20 22:53:33 EDT
In "Steps to Reproduce", above, I forgot to mention that I have
modified the stock kernel*i686*.config file to include the power
management options below.

Here are relevant lines from my kernel .config file:

#
# Power management options (ACPI, APM)
#
CONFIG_PM=y
CONFIG_SOFTWARE_SUSPEND=y
CONFIG_PM_DISK=y
CONFIG_PM_DISK_PARTITION="/dev/hda5"
Comment 2 Arjan van de Ven 2004-06-21 02:49:35 EDT

*** This bug has been marked as a duplicate of 126342 ***
Comment 3 Red Hat Bugzilla 2006-02-21 14:04:10 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.