This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1263900 - The argument in one of examples in man page is wrong
The argument in one of examples in man page is wrong
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-manager (Show other bugs)
7.2
x86_64 Unspecified
low Severity low
: rc
: ---
Assigned To: Pavel Hrdina
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-16 22:58 EDT by xiaodwan
Modified: 2016-11-03 21:58 EDT (History)
4 users (show)

See Also:
Fixed In Version: virt-manager-1.3.2-1.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-03 21:58:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description xiaodwan 2015-09-16 22:58:56 EDT
Description of problem:
The argument in one of examples in man page is wrong

Version-Release number of selected component (if applicable):
virt-install-1.2.1-6.el7.noarch

How reproducible:
100%

Steps to Reproduce:
1. Run "man virt-install", check below example.
       Run a Live CD image under Xen fullyvirt, in diskless environment

         # virt-install \
              --hvm \
              --name demo \
              --memory 500 \
              --disks none \
              --livecd \
              --graphics vnc \
              --cdrom /root/fedora7live.iso

Actual Results:
"--disks none \" is wrong.

Expected results:
it should be "--disk none \".

Additional info:
Comment 2 Pavel Hrdina 2015-10-26 13:12:07 EDT
Upstream commint:

commit 68f0b0572091f4c84071e1e35afaab16107343d3
Author: Pavel Hrdina <phrdina@redhat.com>
Date:   Mon Oct 26 17:56:32 2015 +0100

    man: virt-install: fix a typo in examples
    
    There is no parameter --disks, it should be --disk.
    
    Resolves: https://bugzilla.redhat.com/show_bug.cgi?id=1263900
    
    Signed-off-by: Pavel Hrdina <phrdina@redhat.com>
Comment 4 Mike McCune 2016-03-28 19:17:33 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 6 XiaoyunHu 2016-07-19 04:16:59 EDT
I can reproduce this bug with package:
virt-manager-1.2.1-8.el7.noarch
virt-install-1.2.1-8.el7.noarch

Steps are the same as description above.

Then try to verify with new build:
virt-manager-1.4.0-1.el7.noarch
virt-install-1.4.0-1.el7.noarch

Steps:
1. Run "man virt-install", check below example.


Results:
1. #man virt-install
       Run a Live CD image under Xen fullyvirt, in diskless environment
         # virt-install \
              --hvm \
              --name demo \
              --memory 500 \
              --disk none \
              --livecd \
              --graphics vnc \
              --cdrom /root/fedora7live.iso

According to the result above in the latest version of virt-manager, move this bug from ON_QA to VERIFIED.
Comment 8 errata-xmlrpc 2016-11-03 21:58:19 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2269.html

Note You need to log in before you can comment on or make changes to this bug.