Bug 1263903 - An Error log display when run virt-install with cpuset=auto argument in non-numa host
An Error log display when run virt-install with cpuset=auto argument in non-n...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-manager (Show other bugs)
7.2
x86_64 Unspecified
low Severity low
: rc
: ---
Assigned To: Pavel Hrdina
Virtualization Bugs
:
Depends On:
Blocks: 1288337
  Show dependency treegraph
 
Reported: 2015-09-16 23:08 EDT by xiaodwan
Modified: 2016-11-03 21:58 EDT (History)
4 users (show)

See Also:
Fixed In Version: virt-manager-1.3.2-1.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-03 21:58:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description xiaodwan 2015-09-16 23:08:27 EDT
Description of problem:
An Error log display when run virt-install with cpuset argument in non-numa host.

Version-Release number of selected component (if applicable):
virt-install-1.2.1-6.el7.noarch

How reproducible:
100%

Steps to Reproduce:
1. Run virt-install command with "--vcpus cpuset=auto" in non-numa host.
# virt-install --vcpus cpuset=auto --name cpusettest --memory 1024 --disk none --location http://download.englab.nay.redhat.com/pub/rhel/rel-eng/RHEL-7.1-20150219.1/compose/Server/x86_64/os
ERROR    Not setting cpuset: Capabilities only show <= 1 cell. Not NUMA capable

Actual Results:
"ERROR    Not setting cpuset: Capabilities only show <= 1 cell. Not NUMA capable" is printed out. but the guest is installed successfully.

Expected results:
It should not report an Error in debug logs.

Additional info:
Comment 2 Pavel Hrdina 2015-11-03 05:57:36 EST
Upstream commit:

commit a8110c6cd709f0d439f8d714cd51b1d3d1b84925
Author: Pavel Hrdina <phrdina@redhat.com>
Date:   Mon Nov 2 18:03:33 2015 +0100

    virt-install: report warning for cpuset=auto on non-NUMA host
    
    Currently we report an error but continue with installation, we should
    report warning instead of error.
    
    Resolves: https://bugzilla.redhat.com/show_bug.cgi?id=1263903
    
    Signed-off-by: Pavel Hrdina <phrdina@redhat.com>
Comment 4 Mike McCune 2016-03-28 19:17:33 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 6 XiaoyunHu 2016-07-19 05:28:02 EDT
I can reproduce this bug with package:
virt-manager-1.2.1-8.el7.noarch
virt-install-1.2.1-8.el7.noarch

Steps are the same as description above.

Then try to verify with new build:
virt-manager-1.4.0-1.el7.noarch
virt-install-1.4.0-1.el7.noarch

Steps:
1. Run virt-install command with "--vcpus cpuset=auto" in non-numa host.
# virt-install --vcpus cpuset=auto --name cpusettest --memory 1024 --disk none --location http://download.eng.pek2.redhat.com/pub/rhel/rel-eng/RHEL-6.8-20160414.0/compose/Server/x86_64/os/

Results:
1. There is not error report numa error in debug logs and guest can be installed successfully.

According to the result above in the latest version of virt-manager, move this bug from ON_QA to VERIFIED.
Comment 8 errata-xmlrpc 2016-11-03 21:58:24 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2269.html

Note You need to log in before you can comment on or make changes to this bug.