Bug 1263913 - Upgrading systemd from 219-13.fc22.x86_64 to 219-24.fc22.x86_64 breaks systemd selinux object manager
Upgrading systemd from 219-13.fc22.x86_64 to 219-24.fc22.x86_64 breaks system...
Status: CLOSED DUPLICATE of bug 1264051
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-17 01:00 EDT by Paul
Modified: 2015-09-24 03:05 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-24 03:05:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul 2015-09-17 01:00:37 EDT
Description of problem:

After upgrading to systemd-219-24, the systemd selinux object manager looks broken.

Version-Release number of selected component (if applicable): 219-24


How reproducible: Always


Steps to Reproduce:
1. On a fully updated system PackageKit finds 13 updates related to systemd and selinux:
Upgrading:
 libgudev1                              i686                  219-24.fc22                          updates                 63 k
 libgudev1                              x86_64                219-24.fc22                          updates                 63 k
 selinux-policy                         noarch                3.13.1-128.13.fc22                   updates                422 k
 selinux-policy-devel                   noarch                3.13.1-128.13.fc22                   updates                3.3 M
 selinux-policy-doc                     noarch                3.13.1-128.13.fc22                   updates                964 k
 selinux-policy-targeted                noarch                3.13.1-128.13.fc22                   updates                4.1 M
 systemd                                x86_64                219-24.fc22                          updates                5.9 M
 systemd-compat-libs                    x86_64                219-24.fc22                          updates                137 k
 systemd-journal-gateway                x86_64                219-24.fc22                          updates                337 k
 systemd-libs                           i686                  219-24.fc22                          updates                358 k
 systemd-libs                           x86_64                219-24.fc22                          updates                352 k
 systemd-python                         x86_64                219-24.fc22                          updates                 97 k
 systemd-python3                        x86_64                219-24.fc22                          updates                 98 k

2. Upgrade systemd from 219-13 to 219-24 and selinux from 3.13-122 to 3.13-128
3. Reboot.

Actual results:

After rebooting PackageKit complains that it cannot get authorization. /var/log/messages shows:

PackageKit: uid 1000 is trying to obtain org.freedesktop.packagekit.system-sources-refresh auth (only_trusted:0)
PackageKit: uid 1000 failed to obtain auth

Cannot restart system services with systemctl.

Access Denied.

Additional info:

kernel: 4.1.6-201.fc22.x86_64

This could possibly be related to: https://bugzilla.redhat.com/show_bug.cgi?id=1224211 and https://github.com/systemd/systemd/pull/85#issuecomment-110098645
There was some discussion that this feature would be available for kernel 4.2?  Has the systemd/selinux packages been updated before the required kernel?
Comment 1 Paul 2015-09-17 01:45:50 EDT
I should add that my workaround for this was to downgrade systemd and selinux using:

dnf downgrade systemd selinux-policy --allowerasing

I don't have any problems after that, but the problematic packages still show up as wanting to be installed on any update.
Comment 2 Paul 2015-09-24 02:16:09 EDT
The exact message from PackageKit that appears in the notifications is:

Authorization failed you have failed to provide correct authentication.
Please check any passwords or account settings.
Comment 3 Jan Synacek 2015-09-24 03:05:06 EDT

*** This bug has been marked as a duplicate of bug 1264051 ***

Note You need to log in before you can comment on or make changes to this bug.