Bug 1263918 - implement the new recipe page design
implement the new recipe page design
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: general (Show other bugs)
21
Unspecified Unspecified
unspecified Severity unspecified (vote)
: 23.0
: ---
Assigned To: matt jia
tools-bugs
: FutureFeature, Patch
Depends On: 991245
Blocks: 858911 602131 626529 786793 872094
  Show dependency treegraph
 
Reported: 2015-09-17 01:40 EDT by Dan Callaghan
Modified: 2016-07-07 19:09 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-07 19:09:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Callaghan 2015-09-17 01:40:18 EDT
Implement the new recipe page design, once it is finalised.

https://beaker-project.org/dev/proposals/job-page-improvements.html
Comment 1 matt jia 2016-02-04 22:16:29 EST
The first patch is on Gerrit which covers most of the features that present in the job page improvements.


    http://gerrit.beaker-project.org/#/c/4657/
   

Note: this patch does not show "Possible systems" when a recipe is Queued, so we need to find a solution for it.
Comment 2 Dan Callaghan 2016-02-04 23:03:37 EST
We will also need to come up with something for the existing "Report a problem with this system" button.
Comment 3 matt jia 2016-03-14 02:05:55 EDT
(In reply to matt jia from comment #1)
> The first patch is on Gerrit which covers most of the features that present
> in the job page improvements.
> 
> 
>     http://gerrit.beaker-project.org/#/c/4657/
>    
> 

I have updated this patch with 

http://gerrit.beaker-project.org/#/c/4723/

And other extra supporting patches

http://gerrit.beaker-project.org/#/c/4724/ add db support for commenting on individual recipe tasks and results

http://gerrit.beaker-project.org/#/c/4725/ HTTP APIs for recipe task and result comments 

http://gerrit.beaker-project.org/#/c/4726/ recipe page: add UI for commenting on recipe tasks and results
Comment 4 Dan Callaghan 2016-03-14 02:32:46 EDT
We are getting close now :-)

Summary of remaining issues that need to be fixed on this branch before the recipe page is considered fully implemented:

* link to "possible systems" for a queued recipe
* show aborted/cancelled time for a recipe that was aborted or cancelled without starting
* show export links in the top right, matching the job page (also implement the XML generating endpoints)
* show "Clone Recipe Set" button in the page header, matching the "Clone" button on the job page
* "Netboot configured" item in installation progress is currently using installation.created timestamp, but it needs to look in installation.commands to find the 'configure_netboot' command use that command's .created timestamp instead

We also need to decide what to do about "Report problem with system" button, either find an acceptable place for it to live or drop it.
Comment 5 matt jia 2016-03-16 20:46:59 EDT
(In reply to Dan Callaghan from comment #4)
> We are getting close now :-)

I have put up patches to fix the blow issues.

> Summary of remaining issues that need to be fixed on this branch before the
> recipe page is considered fully implemented:
> 
> * link to "possible systems" for a queued recipe

  http://gerrit.beaker-project.org/#/c/4735/

> * show aborted/cancelled time for a recipe that was aborted or cancelled
> without starting
  
  http://gerrit.beaker-project.org/#/c/4739/

> * show export links in the top right, matching the job page (also implement
> the XML generating endpoints)

  http://gerrit.beaker-project.org/#/c/4736/

> * show "Clone Recipe Set" button in the page header, matching the "Clone"
> button on the job page

  http://gerrit.beaker-project.org/#/c/4737/

> * "Netboot configured" item in installation progress is currently using
> installation.created timestamp, but it needs to look in
> installation.commands to find the 'configure_netboot' command use that
> command's .created timestamp instead

http://gerrit.beaker-project.org/#/c/4738/

> 
> We also need to decide what to do about "Report problem with system" button,
> either find an acceptable place for it to live or drop it.

We have decided to not do this because there is no good place for it on the recipe page. People can still click through the link that links to the system page to report problem. We will revisit this again if we have demands for it in the future.
Comment 6 Mike McCune 2016-03-28 19:06:24 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 7 Dan Callaghan 2016-04-05 03:54:22 EDT
The results-reporting-improvements-take3 branch has been merged to develop.
Comment 10 Dan Callaghan 2016-07-07 19:09:59 EDT
Beaker 23.0 has been released.

Note You need to log in before you can comment on or make changes to this bug.