Bug 1263921 - Validate group names during edit to not contain '/'
Validate group names during edit to not contain '/'
Status: CLOSED CURRENTRELEASE
Product: Beaker
Classification: Community
Component: web UI (Show other bugs)
develop
Unspecified Unspecified
unspecified Severity unspecified (vote)
: 24.0
: ---
Assigned To: Blake McIvor
tools-bugs
: Patch, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-17 01:51 EDT by matt jia
Modified: 2017-02-21 13:48 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-02-21 13:48:46 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description matt jia 2015-09-17 01:51:38 EDT
Description of problem:

In https://bugzilla.redhat.com/show_bug.cgi?id=1251356, the group page is ported to Backbone. It supports to have a group name containing slash '\' and the group url path will contain %2f which is an escaped '/' which will cause 404 error. This is because of a limitation in WSGI(https://github.com/mitsuhiko/flask/issues/900). 


Version-Release number of selected component (if applicable):


How reproducible:

Always

Steps to Reproduce:
1. Update a group name with '/'
2. Go to this group page

Actual results:

404 Not Found 

Expected results:

The page can be loaded successfully.
Comment 1 Blake McIvor 2016-08-03 00:04:29 EDT
https://gerrit.beaker-project.org/#/c/5109/
Comment 4 Roman Joost 2016-08-16 00:20:13 EDT
Dear Wang Dong,

Is it possible you have tested this with the wrong assumption? This bug is about group names shouldn't contain a slash '/'. You've tested this using a backslash '\'. Could you test it again please?
Comment 7 Dan Callaghan 2017-02-21 13:48:46 EST
Beaker 24.0 has been released.

Note You need to log in before you can comment on or make changes to this bug.