Bug 1263930 - Broken, incorrectly formatted man pages for man and apropos
Summary: Broken, incorrectly formatted man pages for man and apropos
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: man-db
Version: 21
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Nikola Forró
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-09-17 06:21 UTC by Wayne Pollock
Modified: 2015-10-05 22:50 UTC (History)
3 users (show)

Fixed In Version: man-db-2.6.7.1-18.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-10-05 22:50:15 UTC


Attachments (Terms of Use)

Description Wayne Pollock 2015-09-17 06:21:20 UTC
Description of problem:

"man man" and "man apropos" show incorrectly formatted pages, full of what look like unexpanded keywords (words surrounded by percent symbols).

Version-Release number of selected component (if applicable):

man-pages-3.69-5.fc21.noarch
man-db-2.6.7.1-16.fc21.x86_64

How reproducible:

Always

Steps to Reproduce:

1. man man
2.
3.

Actual results:

%thman%(1)         Manual pager utils                         %thman%(1)

NAME
       %man% - an interface to the on-line reference manuals
...

Expected results:
MAN(1)             Manual pager utils                             MAN(1)


NAME
       man - an interface to the on-line reference manuals
...

Additional info:

The man page for apropos is similarly formatted.

LANG=en_US.UTF-8
TERM=xterm
Viewed via PuTTY 0.65 (with UTF-8 set)

(By the way, shouldn't the title say "Manual page utils" instead of
"Manual pager utils"?  I noticed that on F22 as well.)

Comment 1 Colin Watson 2015-09-17 09:55:07 UTC
Looks similar to #1231568, only this time for F21.

The title is intentionally "Manual pager utils", and has been that way ever since before I took on upstream maintenance; it's an agent noun construction, i.e. "manual pager" -> "thing that shows manual pages".

Comment 2 Nikola Forró 2015-09-18 08:55:21 UTC
(In reply to Colin Watson from comment #1)
> Looks similar to #1231568, only this time for F21.
Yes, exactly the same problem. Unfortunately I'm unable to find the cause. Rebuilding the package always fixes it, even when I try to emulate the same conditions as with the faulty build.

Comment 4 Fedora Update System 2015-09-22 17:29:27 UTC
man-db-2.6.7.1-18.fc21 has been submitted as an update to Fedora 21. https://bodhi.fedoraproject.org/updates/FEDORA-2015-16443

Comment 5 Fedora Update System 2015-09-22 17:34:51 UTC
man-db-2.7.1-9.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-16445

Comment 6 Fedora Update System 2015-09-22 17:40:35 UTC
man-db-2.7.1-10.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-16446

Comment 8 Fedora Update System 2015-09-23 03:54:12 UTC
man-db-2.7.1-10.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update man-db'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-16446

Comment 9 Fedora Update System 2015-09-23 05:22:37 UTC
man-db-2.6.7.1-18.fc21 has been pushed to the Fedora 21 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update man-db'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-16443

Comment 10 Fedora Update System 2015-09-23 21:21:58 UTC
man-db-2.7.1-9.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update man-db'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-16445

Comment 11 Fedora Update System 2015-09-25 07:56:56 UTC
man-db-2.7.1-10.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2015-10-01 18:49:51 UTC
man-db-2.7.1-9.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2015-10-05 22:50:13 UTC
man-db-2.6.7.1-18.fc21 has been pushed to the Fedora 21 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.