Bug 1263990 - Mail error fails repo sync task and also error is unclear
Mail error fails repo sync task and also error is unclear
Status: CLOSED DUPLICATE of bug 1261068
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Email (Show other bugs)
6.1.2
Unspecified Unspecified
unspecified Severity unspecified (vote)
: Unspecified
: --
Assigned To: Katello Bug Bin
:
Depends On:
Blocks: 1122832
  Show dependency treegraph
 
Reported: 2015-09-17 05:27 EDT by Peter Vreman
Modified: 2015-10-15 20:08 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-15 20:08:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
export of failing task (139.80 KB, application/x-gzip)
2015-09-17 07:02 EDT, Peter Vreman
no flags Details

  None (edit)
Description Peter Vreman 2015-09-17 05:27:22 EDT
Description of problem:
When Notifications are configured for a user, then errata mails are trying to be send out after a RedHat repository sync.
Somehow the mail server configuration is not correct. Then the task fails with with the very generic "getaddrinfo: Name or service not known". At first glance you think of the Pulp repo sync that could not resolve find the url upstream server. Only after a closer in Backtrace in the 3rd Action you see that the Actions::Katello::Repository::ErrataMail triggered the error and did a Pulp Cancel.

For the User it would be more helpful to be informed that the real error was that the Errata Mail could not be send.

Additionally From a User i see Errata Mail as a independent Action that is executed after the original Action (e.g. Repository Sync) succeeded. Because i my case the Repository Sync was in fact successful finished.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Make sure the Mail server is not set or to a not existing domain name
2. Enable All notifications for a User
3. Sync RedHat Repositories
3.

Actual results:
Repo Sync Fails

Expected results:
Repo Sync Fails
Errata Mail Action Fails with clear error message that the Mail server could not be found


Additional info:
Comment 1 Peter Vreman 2015-09-17 07:02:24 EDT
Created attachment 1074398 [details]
export of failing task
Comment 2 Peter Vreman 2015-09-17 08:09:38 EDT
Rewording of Expected Results:
- Reposync Task Succeeds
- Indepedent ErrataMail Task Fails
Comment 3 Peter Vreman 2015-09-17 08:43:26 EDT
The behavior can be triggered when the out-of-the-box email.yaml is used that has a dummy smtp server value:

$ cat /etc/foreman/email.yaml
# Outgoing email settings

production:
  delivery_method: :smtp
  smtp_settings:
    address: smtp.example.com
    port: 25
    domain: example.com
    authentication: :none
Comment 4 Peter Vreman 2015-09-17 09:36:38 EDT
Being referenced from other BZs I have found https://access.redhat.com/solutions/1579953 that mentions this issue also and also the fix how to configure it.

But I did not find any BZ that asked for solving the real issue behind it, that an failing ErrataMail shall not make a Successful repositories Syncs failing.
Comment 5 Brad Buckingham 2015-10-15 20:08:46 EDT

*** This bug has been marked as a duplicate of bug 1261068 ***

Note You need to log in before you can comment on or make changes to this bug.