Bug 1264010 - Copy text => paste quotation in email reply "hangs" evolution
Copy text => paste quotation in email reply "hangs" evolution
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomas Popela
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-17 06:13 EDT by Severin Gehwolf
Modified: 2015-09-22 12:25 EDT (History)
4 users (show)

See Also:
Fixed In Version: evolution-3.17.92
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-22 12:25:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Backtrace of evolution process when this happened. (17.66 KB, text/plain)
2015-09-17 06:16 EDT, Severin Gehwolf
no flags Details
Backtrace of evolution-addressbook-factory when it happened (3.22 KB, text/plain)
2015-09-17 06:17 EDT, Severin Gehwolf
no flags Details

  None (edit)
Description Severin Gehwolf 2015-09-17 06:13:55 EDT
Description of problem:
When composing an email reply and trying to "paste quotation" some text from the original email's patch attachment (shown inline) evolution seems to hang and needs to be killed -9.

Version-Release number of selected component (if applicable):
$ rpm -qa | grep evolution
evolution-3.17.91-1.fc23.x86_64
evolution-ews-3.17.91-1.fc23.x86_64
evolution-data-server-3.17.91-1.fc23.x86_64
evolution-help-3.17.91-1.fc23.noarch

How reproducible:
100%

Steps to Reproduce:
1. Send email to yourself with .patch as an attachment.
2. View email in evolution (double click)
3. Hit group reply. Then go back to email window opened via step 2.
4. View patch attachment inline in the email viewer.
5. Select portion of the attachment. copy using ctrl+c
6. Go back to reply email created in step 3.
7. right-click -> paste quotation

Actual results:
Evolution email composer seems to hang.

Expected results:
Composer window contains paste in quoted form in email reply. Ready to send reply. No hang.
Comment 1 Severin Gehwolf 2015-09-17 06:16:02 EDT
Created attachment 1074384 [details]
Backtrace of evolution process when this happened.

Used command:
gdb --batch --ex "t a a bt" -pid $(pidof evolution) &> evo-bt.txt
Comment 2 Severin Gehwolf 2015-09-17 06:17:25 EDT
Created attachment 1074385 [details]
Backtrace of evolution-addressbook-factory when it happened

Used command:
gdb --batch --ex "t a a bt" -pid=`pidof evolution-addressbook-factory` &>eaf-bt.txt
Comment 3 Severin Gehwolf 2015-09-17 06:20:21 EDT
It seems to be eating up a lot of memory too.
Comment 4 Severin Gehwolf 2015-09-17 07:40:29 EDT
Having something like this in an email body, then simply replying to it triggers this as well:


diff -r f1c49b5c4ff5 setup/command/src/main/java/com/redhat/thermostat/setup/command/internal/SetupWindow.java
--- a/setup/command/src/main/java/com/redhat/thermostat/setup/command/internal/SetupWindow.java Tue Sep 15 16:58:10 2015 -0400
+++ b/setup/command/src/main/java/com/redhat/thermostat/setup/command/internal/SetupWindow.java Wed Sep 16 23:12:45 2015 -0400
@@ -141,7 +141,11 @@
                 IOException finishException = finishAction.get();
                 if (finishException != null) {
                     logger.log(Level.INFO, "Setup failed.", finishException);
-                    showErrorDialog(finishException);
+                    if (finishException.getMessage().contains("Storage already running")) {
+                        showErrorDialog(translator.localize(LocaleResources.STORAGE_RUNNING).getContents());
+                    } else {
+                        showErrorDialog(finishException);
+                    }
Comment 5 Milan Crha 2015-09-22 01:55:28 EDT
Thanks for a bug report. I tried to reproduce this with your test patch, but no luck here, evolution doesn't get into the busy loop. The addressbook factory is idle, according to the backtrace, but the evolution itself is trying to wrap the text you are pasting, which might be due to some corner case on the calculation. 

There is filled a similar bug upstream:
https://bugzilla.gnome.org/show_bug.cgi?id=732457
Comment 6 Severin Gehwolf 2015-09-22 06:01:19 EDT
evolution-3.17.92-1.fc23.x86_64 seems to have fixed this. Came in with a recent updates-testing update.
Comment 7 Milan Crha 2015-09-22 12:25:04 EDT
Thanks for the follow-up. You are right, that version contains several changes in the related parts of the code. I'm closing this accordingly.

Note You need to log in before you can comment on or make changes to this bug.